PROBLÈME

les versions de Safari antérieures à la version 10.0.2 utilisées pour exécuter les applications ArcGIS for JavaScript API nécessitant WebGL peuvent donner lieu à l’affichage d’un écran noir ou vert

Last Published: April 25, 2020

Description

Exécuter une application Esri ou personnalisée intégrée à ArcGIS API for JavaScript version 4.x peut aboutir à un écran noir ou un écran vert dans le navigateur Safari d’Apple. Il s’agit notamment de Scene Viewer, Web AppBuilder, 3D Templates et de GeoPlanner ; d’autres programmes peuvent également être concernés.

Cause

Ce problème est lié à l’implémentation WebGL (Web Graphics Library) du navigateur Safari d’Apple.

Solution ou alternative

Si vous rencontrez ce problème, vérifiez la version de Safari. Si la version du navigateur ne correspond pas à la version 10.0.2 ou à une version ultérieure, mettez à niveau le navigateur. Si vous n’avez pas la possibilité d’effectuer la mise à niveau, utilisez un autre navigateur pour contourner le problème.

ID d’article:000015277

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

En savoir plus sur ce sujet