PROBLÈME

la mise à niveau vers ArcGIS License Server 2022.0 ou version ultérieure entraîne une défaillance du stockage approuvé, rendant non valides les licences existantes

Last Published: May 20, 2023

Description

Note:
The issue only occurs on virtual machines in the Microsoft Azure Cloud environment.

Une fois que vous avez installé ArcGIS License Manager 2021.1 ou version antérieure et l’avez autorisé avec des licences flottantes, le dossier Availability (Disponibilité) affiche toutes les licences autorisées sur la machine. Les nombres de licences autorisées sont affichés dans les colonnes Total et Available (Disponible). Le nombre dans la colonne Available (Disponible) correspond au nombre total de licences disponibles pour l’extraction.  

Après la mise à niveau vers ArcGIS License Manager 2022.0 ou version ultérieure et le retour au dossier Availability (Disponibilité), vous remarquerez que la valeur est « 0 » pour toutes les licences dans la colonne Available (Disponible). Les licences ont été autorisées, mais aucune ne peut être extraite.  

Cause

ArcGIS License Manager utilise un composant tiers, le service de licence FlexNet. Pour ArcGIS License Manager 2022.0, nous avons mis à niveau le service de licence de la version 11.18.2.0 vers la version 11.18.3.0 afin de résoudre les bogues existants et les problèmes associés. Malheureusement, la mise à niveau modifie le service de licence FlexNet et la façon dont il détecte et lit le numéro de machine unique (UMN), l’un des composants utilisés par le stockage approuvé pour identifier la machine. Cette modification a également un impact sur l’ID d’instance Cloud, un autre composant utilisé pour identifier la machine. Elle a endommagé le stockage approuvé, rendant les licences existantes non valides.

Etapes pour reproduire

  1. Installez ArcGIS License Manager 2021.1 ou version antérieure.
  2. Autorisez-le avec des licences ArcMap ou ArcGIS Pro.
  3. Accédez au dossier Availability (Disponibilité) et vérifiez que des licences sont répertoriées dans la colonne Available (Disponible), indiquant qu’elles sont actives et prêtes à être extraites.
  4. Effectuez une mise à niveau vers ArcGIS License Manager 2022.0 ou version ultérieure.
  5. Retournez dans le dossier Availability (Disponibilité).  Vous constatez que le nombre de licences figurant dans la colonne Available (Disponible) a été remplacé par la valeur No (Aucune), ce qui indique qu’aucune licence n’est prête à être extraite.

Solution ou alternative

  1. Rétrogradez, puis mettez à niveau le gestionnaire de licences.
    1. Rétrogradez vers la version précédente du gestionnaire de licences.
    2. Annulez l’autorisation relative aux licences existantes.
    3. Effectuez une mise à niveau vers ArcGIS License Manager 2022.0 ou version ultérieure.
    4. Autorisez à nouveau les licences.
  2. Contactez le support technique Esri. Un analyste vous guidera tout au long du processus pour :
    1. Remplir la demande de récupération des licences perdues.
    2. Supprimer l’intégralité du contenu dans le stockage approuvé.
    3. Procéder à l’autorisation avec les nouvelles licences flottantes.

ID d’article: 000030616

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