PROBLÈME

impossible de créer une collaboration entre des portails ArcGIS Enterprise

Last Published: August 21, 2020

Description

Dans Portal for ArcGIS, lorsque vous essayez de créer une collaboration depuis le « portail A » vers le « portail B », l’invitation demandée est envoyée au portail B. Toutefois, au cours de la procédure, la connexion échoue avec l’erreur suivante :

Error: 
Erreur de certificat SSL

Échec de la validation du certificat SSL de https:///portal. L’autorité de certification qui a émis le certificat SSL doit être approuvée par le portail pour que l’invitation soit acceptée. Pour plus d’informations, reportez-vous à la rubrique Configuration du portail de manière à approuver les certificats.

SSL Certificate Error

Cause

Ce problème est provoqué par une autorité de certification non approuvée entre le portail A et le portail B. Les deux portails doivent être configurés pour que l’invitation soit acceptée. Il est par exemple possible de créer une collaboration avec un certificat auto-signé, car tous les portails de la collaboration doivent approuver l’autorité de certification. Pour plus d’informations, reportez-vous à la rubrique Conditions préalables à la création d’une collaboration.

Solution ou alternative

Dans le cas de Portal for ArcGIS qui utilise des certificats auto-signés, procédez comme suit.

  1. Exportez le certificat auto-signé depuis IIS pour le portail A. Pour plus d’informations, reportez-vous à la page d’aide de Windows Server, Exporter un certificat Server (IIS 7).
  2. Importez le certificat dans le portail B. Pour plus d’informations, reportez-vous à la rubrique Importer le certificat racine de l’autorité de certification.
  3. Répétez la même procédure pour exporter le certificat du portail B et l’importer dans le portail A.

Dans le cas de Portal for ArcGIS qui utilise une autorité de certification, reportez-vous à la rubrique Configuration du portail de manière à approuver les certificats de votre autorité de certification..

Remarque :
Une fois la mise à jour terminée, l’importation des certificats provoque le redémarrage de Portal for ArcGIS. Dans certains cas, cette opération peut déclencher le basculement d’un portail haute disponibilité. 

ID d’article:000015345

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement