Message d’erreur
La tentative de fédération d’ArcGIS for Server avec Portal for ArcGIS génère l’erreur suivante :
« Une erreur s’est produite lors de la communication avec le serveur. Vérifiez votre URL et vos informations d’identification, puis réessayez. »
Cause
Il s’agit d’un problème connu lorsque vous accédez à Portal for ArcGIS via un alias Domain Naming System (DNS). Une non-concordance de l’URL des services et de l’URL d’administration dans la certification entraîne l’échec de la fédération.
Solution ou alternative
Remarque : Il est possible de résoudre ce problème en inscrivant à nouveau Portal Web Adaptor avec l’alias DNS. Si l’inscription de Web Adaptor avec l’alias DNS ne parvient pas à résoudre le problème, effectuez la procédure ci-dessous.
- Connectez-vous au serveur Web IIS (Internet Information Services).
- Générez un certificat auto-signé pour le nom de domaine complet du serveur Web IIS en suivant les instructions figurant dans le document ArcGIS Resources Enabling SSL using a self-signed certificate.
- Liez le certificat auto-signé au port 443.
- Lancez un navigateur Web à partir du serveur Web IIS et accédez au portail via l’URL du nom de domaine complet du serveur Web IIS (FQDN) et de l’URL de Web Adaptor.
- Exécutez le traitement de fédération entre ArcGIS for Server et Portal for ArcGIS.
- Validez la fédération sur la page de Portal page via le FQDN ou le Web Adaptor du serveur Web IIS.
- Réinitialisez la liaison de certificat dans IIS Manager vers le certificat auto-signé nouvellement créé.
- Vérifiez la fédération en vous connectant aux extrémités ArcGIS Server Manager et Admin pour vous assurer qu’un jeton de portail a été demandé.