Description
La recherche d’une adresse dans un modèle Solutions ArcGIS hébergé sur site ne renvoie aucun résultat lorsqu’une adresse valide est géocodée.
Les applications impactées recensées sont les suivantes :
- Park Locator
- Water Access Locator
- Event Calendar
- Event Locator
- Shelter Locator
- WMA Locator
- Impact environnemental
- Executive Dashboard
- Live Work Locate
- Permit Status
- Site Selector
- Transportation 511
Remarque : Les versions Web AppBuilder d’Environmental Impact et de Transportation 511 ne sont pas concernées. La mise à niveau de la version sur site vers la version Web AppBuilder de ces solutions permet également de résoudre ce problème.
Cause
Ce problème est dû à une non-concordance entre la casse des paramètres de géocodage trouvés dans la configuration de l’application et la configuration requise du service de géocodage mondial au niveau de la version 10.5 (version de juin d’ArcGIS Online).
Solution ou alternative
- Ouvrez le fichier de configuration associé à l’application. Ce fichier se trouve normalement dans le répertoire racine de l’application ou le dossier js, et est généralement nommé config.js ou doté d’un nom similaire.
- Localisez la section du fichier de configuration dans lequel les paramètres de géocode sont définis. Cette section commence généralement par Locator, Locators ou LocatorSettings.
- Mettez à jour la casse des valeurs des paramètres du géocodeur afin de les faire correspondre avec ce qui suit, quel que soit l’endroit où elles sont utilisées avec le service de géocodage mondial : "Addr_type", "Type", "Score", "Match_addr", "Xmin", "Xmax", "Ymin", "Ymax"
- Si cela ne résout pas le problème, vérifiez la casse de tous les autres paramètres de localisateurs indiqués par rapport à la réponse du localisateur. La liste complète des paramètres de réponse avec la casse correcte se trouve également dans la documentation du service de géocodage mondial.