BOGUE

code d’erreur 498 « Invalid Token » (Jeton non valide) renvoyé après consultation des images dans l’application Story Map Journal

Last Published: April 24, 2024

Description

Under some circumstances, images in the side panel of Story Map Journal applications stop displaying. The application operates as expected if the Story Map Journal is created and shared privately or to an ArcGIS Online organization / Portal for ArcGIS, when photos are added to the side panel. The application also operates as expected if shared publicly. However, if any edits are made to the application after being shared publicly, all images added to the app prior to being publicly shared become unavailable after two weeks. An outline and broken icon display instead of the actual image. If sharing settings are subsequently changed back to private (or to Org/Portal only), the images become available again, but any time it is shared publicly again, the images disappear.

Cause

This issue is due to tokens that are appended to the image URL once edits on a publicly shared application have been saved. Tokens allow access to a specific item for a given period of time, which can range from a few seconds up to two weeks. In this specific scenario, a two-week token is appended to each individual image, which is why the issue appears to occur at a random time. The following bug has been logged. 

​BUG-000104841: If changes are made to a Story Map Journal application after panel images are saved when the application is private and then shared publicly, tokens are appended to the images when the application is public-facing, resulting in broken images after the tokens expire. 

Solution de contournement

Use one or more of the following workarounds to resolve this issue.

  • Replace the images while Application is still public-facing.
  • Immediately share the application publicly before adding any photos to the Panel.
  • Remove <?token=[RandomGeneratedCode]> from the Javascript Object Notation (JSON) of the application via ArcGIS Online Assistant.
    Note:
    Usage of ArcGIS Online Assistant is not supported by Esri Support Services and is for advanced users only. Mistakes made when editing the JSON of an application can irrevocably break the application. Please create a backup copy of the JSON before editing. For these reasons, this workaround is not generally recommended.

This issue is expected to be resolved in the June 2017 release of ArcGIS Online, and at the end of 2017 for Portal for ArcGIS (version 10.6). In the June 2017 release, GitHub contains a downloadable Story Map template available for download that prevents this bug from happening in new stories.

ID d’article: 000016034

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