PROBLÈME

impossible d’activer le mode hors connexion dans les réglages de la carte web

Last Published: April 25, 2020

Description

Le mode hors connexion peut être activé pour collecter et mettre jour les données d’une carte web de sorte que la carte puisse être utilisée hors connexion par des applications telles que Collector for ArcGIS. Or, dans certaines circonstances, la section Offline (Hors connexion) n’est pas disponible dans l’onglet Settings (Paramètres) de la page des éléments de la carte web. L’image suivante illustre la section Offline (Hors connexion) de la page des éléments.

Screenshot of the Offline section in the Settings tab of a web map's item details.

Cause

Pour activer le mode hors connexion, une carte web doit satisfaire à toutes les conditions d’une utilisation hors connexion comme stipulé dans cette documentation. Outre ces conditions, voici les raisons possibles selon lesquelles le mode hors connexion n’est pas activé :

La synchronisation n’est pas activée sur toutes les couches d’entités dans la carte web.
Les couches d’entités sur lesquelles la synchronisation n’est pas activée ne sont pas prises en charge en mode hors connexion.

La carte web contient des services de carte mis en cache comportant des structures de tuilage personnalisées.
Il s'agit d'une limitation connue. Il est impossible d’activer le mode hors connexion si la carte web possède un service de carte mis en cache dont la structure de tuilage est personnalisée.
 
Utilisation d’un fond de carte non pris en charge.
Tous les fonds de carte Esri sont automatiquement activés pour être utilisés en mode hors connexion, mais toutes les applications ArcGIS ne prennent pas en charge l’utilisation de fonds de carte (les fonds de carte vectoriels, notamment). Par exemple, le mode hors connexion d’une carte web est activée, mais Collector for ArcGIS ne parvient pas à télécharger la carte web pour une utilisation hors connexion si le fond de carte est un fond de carte vectoriel Esri.

Solution ou alternative

Selon la cause, utilisez l’une des solutions ci-dessous :

Activer la synchronisation sur toutes les couches d’entités.
Assurez-vous que la synchronisation est activée sur toutes les couches d’entités dans la carte web. Pour plus d’informations sur le fait d’activer la synchronisation dans une couche d’entités hébergée, consultez les procédures de mise à jour ou collaboration hors connexion pour ArcGIS Online ou ArcGIS GIS Server. Pour activer la synchronisation pour un service d’entités ArcGIS Server, reportez-vous à ArcGIS Server : Préparer des données pour une utilisation hors connexion.

Utilisez la structure de tuilage de ArcGIS Online par défaut.
Publiez un service de carte mis en cache avec la structure de tuilage ArcGIS Online par défaut.

Utilisez le fond de carte raster par défaut.
Assurez-vous que l’application prend en charge le fond de carte utilisé pour la carte web conformément à la documentation de l’application.

ID d’article:000017769

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement