PROBLÈME

impossible de se connecter à Portal for ArcGIS à l’aide d’ArcGIS Pro

Last Published: June 11, 2021

Description

Après avoir ajouté un déploiement ArcGIS Enterprise récemment configuré en tant que portail actif dans ArcGIS Pro, la connexion au moyen d’un identifiant de connexion d’entreprise se solde par un échec. L’URL de Portal for ArcGIS est correctement ajoutée à la liste Portals dans ArcGIS Pro, mais son état reste « Not signed in » (Non inscrit).

La page ArGIS Pro Portal indiquant Not signed in (Non inscrit)

Cause

L’URL de contexte Web de Portal for ArcGIS dans le répertoire d’administration du portail contient un point de terminaison REST non valide. L’exemple ci-dessous présente une URL de contexte Web incorrect web.

https://webadaptorhost.domain.com/webadaptorname/home

Le format URL de contexte Web de Portal for ArcGIS correct est le suivant :

https://webadaptorhost.domain.com/webadaptorname

Solution ou alternative

Dans le répertoire d’administration du portail, supprimez le point de terminaison REST non valide dans les propriétés WebContextURL et mettez à jour le fichier de configuration portal-config.properties.

  1. Mettez à jour l’élément WebContextURL via le répertoire d’administration du portail. Pour obtenir la procédure détaillée, consultez Portal for ArcGIS : Définir la propriété WebContextURL.
  2. Mettez à jour le fichier de configuration portal-config.properties en supprimant le point de terminaison REST non valide. Parcourez les fichiers pour atteindre le répertoire présenté ci-dessous et ouvrez le fichier portal-config.properties dans un éditeur de texte.
C:\<Répertoire d’installation Portal for ArcGIS>\content\items\portal
  1. Mettez à jour le paramètre WebContextURL pour adopter le format suivant.
https://webadaptorhost.domain.com/webadaptorname

Dans cet exemple, « /home » a été supprimé du paramètre WebContextURL.

Le fichier portal-config.properties

ID d’article: 000025343

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement