PROBLÈME

impossible d’enregistrer des mises à jour dans Web AppBuilder for ArcGIS

Last Published: June 5, 2020

Description

Dans certains cas, lorsque vous utilisez Web AppBuilder for ArcGIS, le bouton Save (Enregistrer) n’est pas disponible et il n’est pas possible d’enregistrer les mises à jour, comme illustré dans l’image ci-dessous.

Image représentant le bouton Save (Enregistrer) non disponible

Cause

Voici quelques causes connues :

  • Les données de l’application Web ne se chargent pas correctement.
  • L’application Web est une application partagée et des modifications sont effectuées par plusieurs utilisateurs simultanément.
  • Le code source de l’application Web est modifié.

Solution ou alternative

Selon la cause, utilisez l’une des solutions ci-dessous pour résoudre ce problème :

Recharger l’application Web

  • Redimensionnez la fenêtre du navigateur. Cela permet au bouton Save (Enregistrer) d’enregistrer les mises à jour apportées à l’application Web.
  • Sur la page de l’application Web, sélectionnez un autre thème et cliquez sur Save (Enregistrer). Relancez l’application Web.
  • Chargez l’application Web dans un autre navigateur. Effectuez les mises à jour requises et cliquez sur Save (Enregistrer).

Limiter l’accès à l’application Web à un utilisateur à la fois

Assurez-vous qu’aucun autre utilisateur ne met à jour l’application Web simultanément si l’application Web est une ressource partagée.

Vérifier et remplacer le JSON de l’application Web

Remplacez le JSON de l’application Web à l’aide d’ArcGIS Online Assistant pour une nouvelle configuration de l’application Web.

Avertissement : ArcGIS Online Assistant ne relève pas du support technique Esri. Le support technique n’est pas responsable des modifications incorrectes effectuées à l’aide de cet outil.
Remarque : Enregistrez une copie du code d’origine avant de modifier le JSON de l’application Web. Esri recommande de modifier le code sur une copie de l’application Web au lieu de modifier le code de l’application Web d’origine.
  1. Sur la page de l’application Web d’origine, cliquez sur Save As (Enregistrer sous) pour créer une nouvelle application Web dans laquelle les mises à jour sont appliquées.
  2. Accédez à ArcGIS Online Assistant et sélectionnez Log in to ArcGIS Online (Se connecter à ArcGIS Online).
  3. Connectez-vous avec les identifiants de connexion nécessaires.
  4. Dans la barre de menu, cliquez sur I want to... (Je veux...) > View an Item’s JSON (Afficher le JSON d’un élément).
  5. Pour la liste déroulante Root (Racine), accédez à la nouvelle application Web et cliquez sur Item ID (ID de l’élément).
  6. Sous la section Description du JSON de l’élément, cliquez sur Copy JSON (Copier le JSON)Image de l’icône Copy JSON (Copier le JSON).
  7. Revenez à la liste déroulante Root (Racine) et accédez à l’application Web d’origine. Cliquez sur Item ID (ID de l’élément).
  8. Dans la section Description du JSON de l’élément, cliquez sur Edit JSON (Mettre à jour le JSON) pour coller le code copié à l’étape 6.
  9. Lorsque vous y êtes invité, cochez la case I understand the risks (Je comprends les risques), puis cliquez sur Proceed (Continuer).
  10. Collez le code copié depuis la nouvelle application Web dans le JSON de l’application Web d’origine.
  11. Cliquez sur JSON is valid (JSON valide). Cliquez pour enregistrer. Image de l’icône JSON is valid (JSON valide) .

Recréer l’application Web

Créez une nouvelle application Web dans laquelle les mises à jour requises sont appliquées.

Remarque : Cette opération crée une nouvelle application Web avec une nouvelle URL.

ID d’article:000023192

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet