PROBLÈME

impossible d’installer un paquetage Python dans le gestionnaire de paquetages Python d’ArcGIS Pro

Last Published: April 25, 2020

Description

Lors de l’installation d’un paquetage Python dans le gestionnaire de paquetages Python d’ArcGIS Pro, le bouton Install (Installer) est désactivé.

Cause

À compter de la version 2.2 d’ArcGIS Pro, l’environnement arcgispro-py3 par défaut est défini sur lecture seule, de sorte qu’aucun nouveau paquetage ne puisse être installé dans l’environnement par défaut.

Solution ou alternative

Créez ou clonez un environnement à partir de l’environnement par défaut et installez le paquetage Python dans le nouvel environnement. Pour cloner un environnement, procédez comme suit.

  1. Lancez ArcGIS Pro et ouvrez un projet.
  2. Cliquez sur Project (Projet) > Python.
  3. Cliquez sur Manage Environments (Gérer les environnements).
    Phython Package Manager
  4. Cliquez sur Clone (Cloner).
    Manage Environments window
  5. Vérifiez que l’environnement cloné est activé (Active).
    Manage Environments window with active tab
  6. Redémarrez ArcGIS Pro.
  7. Installez le paquetage Python.
Remarque :
Il existe une limitation connue en matière de clonage des environnements depuis le gestionnaire de paquetage Python dans ArcGIS Pro 2.2. Ce problème est résolu dans ArcGIS Pro 2.3. Pour en savoir plus et obtenir une solution pour ArcGIS Pro 2.2, reportez-vous à : Problème : impossible de créer des environnements ou d’installer des packages après la mise à niveau vers ArcGIS Pro 2.2

ID d’article:000020279

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement