PROBLÈME

impossible de configurer un modèle de service d’impression personnalisé dans ArcGIS Experience Builder

Last Published: May 17, 2023

Description

Dans ArcGIS Experience Builder, le widget Print (Imprimer) est utilisé pour imprimer des cartes Web et permet de sélectionner des mises en page à partir de modèles d’impression ajoutés à l’aide d’un service utilitaire d’impression. Parfois, un service d’impression personnalisé est ajouté au widget Print (Imprimer) à l’aide de l’URL du service, mais les modèles d’impression ne sont pas affichés et ne peuvent pas être configurés.

Cause

Le mode d’exécution du service d’impression personnalisé est défini sur asynchrone. ArcGIS Experience Builder utilise ArcGIS Maps SDK forJavaScript 4.x et prend uniquement en charge le mode d’exécution synchrone. Reportez-vous aux rubriques ArcGIS Experience Builder : À propos des versions et Portal for ArcGIS : Impression pour plus d’informations.

Solution ou alternative

Dans ArcGIS Server Manager, définissez le paramètre Execution Mode (Mode d’exécution) du service d’impression personnalisé sur Synchronous (Synchrone).

  1. Ouvrez ArcGIS Server Manager et connectez-vous avec un compte d’administrateur.
  2. Cliquez sur Services > Manage Services (Gérer les services). Accédez au service d’impression personnalisé et cliquez dessus.
  3. Cliquez sur Parameters (Paramètres) et sélectionnez Synchronous (Synchrone) sous le paramètre Execution Mode (Mode d’exécution).
  4. Cliquez sur Save (Enregistrer).
Paramètres du service d’impression personnalisé.

ID d’article: 000030278

Obtenez de l'aide avec l'IA

Résolvez rapidement votre problème avec le chatbot Esri Support AI.

Commencez à discuter maintenant

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Commencez à discuter maintenant

Accéder aux options de téléchargement