PROBLÈME

l’option de changement de propriétaire n’est pas disponible dans ArcGIS Online

Last Published: May 20, 2025

Description

Lorsqu’un membre quitte l’organisation, l’administrateur doit transférer le contenu avant de pouvoir supprimer le compte du membre. Cependant, il arrive que l’option Change Owner (Changer le propriétaire) ne s’affiche pas lors de la modification de la propriété de la carte Web, comme illustré dans l’image ci-dessous.

L’option Change Owner (Changer le propriétaire) ne s’affiche pas.

Cause

  • La carte Web contient ou contenait à un moment donné des zones cartographiques hors connexion. Parfois, même après avoir identifié la carte Web et supprimé les zones hors connexion de la carte Web, il arrive que l’option Change Owner (Changer le propriétaire) ne soit toujours pas affichée. Cela peut être dû à une interruption soudaine de la connexion lors de la suppression des zones hors connexion, ce qui fait que la ligne "Offline Map Areas" apparaît encore dans le script JSON de la carte Web.
  • La carte Web est peut-être endommagée.

Solution ou alternative

Supprimer les zones hors connexion de la carte Web

  1. Connectez-vous à ArcGIS Online et accédez à Content (Contenu) > My Content (Mes contenus).
  2. Recherchez et cliquez sur la carte Web.
  3. Sur la page de détails des éléments, cliquez sur Settings (Paramètres).
  4. En haut de la page, cliquez sur l’onglet Offline (Hors connexion).
  5. Dans la section Offline Map Areas (Zones cartographiques hors connexion), cliquez sur Manage Offline Areas (Gérer les zones cartographiques hors connexion).
  6. Dans le volet Offline map areas (Zones cartographiques hors connexion), cochez la case correpondant aux zones hors connexion et sélectionnez Delete (Supprimer) dans le menu déroulant.
  7. Dans le coin supérieur droit de la page, cliquez sur le bouton Close (Fermer) pour revenir à la page Settings (Paramètres).
  8. Dans la section Offline (Hors ligne), désactivez l’option Enable offline mode (Activer le mode hors ligne).
  9. Cliquez sur Save (Enregistrer).
Bouton bascule Enable offline mode (Activer le mode hors ligne) sous la section Hors ligne.
Note: 
If the issue still persists, contact Esri Support Services.

Si l’option de modification du propriétaire ne s’affiche toujours pas lors de la modification de la propriété de la carte Web, modifiez le fichier JSON de la carte Web dans ArcGIS Online Assistant. Cette solution de contournement est effectuée dans ArcGIS Online Assistant, car le script JSON ne peut pas être modifié directement dans ArcGIS Online.

Warning:
ArcGIS Online Assistant is not supported by Esri.
Warning:
It is not recommended to modify the JSON script of the item as it may corrupt or break the item.
  1. Connectez-vous à ArcGIS Online Assistant.
  2. Sélectionnez le menu déroulant I want to (Je veux...), puis sélectionnez View an Item’s JSON (Afficher le JSON d’un élément).
  3. Dans le volet de liste de l’élément à gauche de la page, développez le dossier, puis recherchez et cliquez sur la carte Web.
Cliquez sur la carte Web après avoir développé le dossier dans le volet de la liste correspondant à l’élément.
  1. Cliquez sur Edit JSON (Modifier JSON) et recherchez la ligne "Offline Map Areas" (Zones cartographiques hors ligne).
Script JSON de la carte Web.
  1. Supprimez la ligne "Offline Map Areas" (Zones cartographiques hors ligne) du script JSON.
  2. Cliquez sur JSON is valid. Click to save (JSON valide. Cliquez pour enregistrer.).
La ligne "Offline Map Areas" (Zones cartographiques hors ligne) a été supprimée du script JSON de la carte Web.

Enregistrer une copie de la carte Web dans ArcGIS Online

Dans ArcGIS Online, effectuez une copie et enregistrez la carte en tant que nouvelle carte Web à l’aide de l’option « Save as » (Enregistrer sous). Pour des instructions plus détaillées, reportez-vous à la rubrique ArcGIS Online : Enregistrer les cartes (Map Viewer).

L’image ci-dessous montre l’option Change Owner (Changer le propriétaire) affichée dans ArcGIS Online.

L’option Change Owner (Changer le propriétaire) est maintenant affichée.

ID d’article: 000031171

Obtenez de l'aide avec l'IA

Résolvez rapidement votre problème avec le chatbot Esri Support AI.

Commencez à discuter maintenant

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Commencez à discuter maintenant

Accéder aux options de téléchargement