PROBLÈME

l’application de terrain Survey123 for ArcGIS (Windows) ne parvient pas à s’ouvrir via la structure URL

Last Published: April 27, 2022

Description

L’application de terrain Survey123 for ArcGIS ne réussit pas à s’ouvrir lorsque l’utilisateur saisit son URL (à savoir, ArcGIS-survey123://). Elle est pourtant installée et s’ouvre directement sans aucun problème.

L’accès à l’URL de Survey123 for ArcGIS renvoie le message : « Voulez-vous autoriser ce site Web à ouvrir une application sur votre ordinateur ? »
Si vous cliquez sur Allow (Autoriser), le message « Vous aurez besoin d’une nouvelle application pour ouvrir cet élément ArcGIS-survey123 » s’affiche.

Image of Internet Explorer prompt to allow website to run app
Image of Windows prompt to find new app

Cause

Les clés de Registre Windows associant la structure URI à l’application ne figurent pas sur la machine. Les clés de Registre sont créées au moment de l’installation de Survey123 for ArcGIS. La mise à jour du Registre est vraisemblablement bloquée par un paramètre de sécurité Windows, un anti-virus ou tout autre logiciel de contrôle de la sécurité.

Remarque :
Pour plus d’informations sur la manière dont sont enregistrées les structures URI, consultez la documentation de Microsoft portant sur l’enregistrement d’une application dans une structure URI : registering an application to a URI scheme.

Solution ou alternative

Réinstaller Survey123 for ArcGIS avec des privilèges d’administration

Remarque :
Les utilisateurs seront peut-être amenés à contacter leur administrateur système pour réaliser les étapes suivantes.
  1. Identifiez la stratégie ou l’application qui empêche la mise à jour du Registre par Survey123 for ArcGIS à l’installation. En cas de doute, contactez l’administrateur système.
  2. Désactivez/contournez la stratégie.
  3. Réinstallez Survey123 for ArcGIS.

Si, malgré cela, le problème persiste, appliquez les instructions suivantes.


Créer des clés de Registre manuellement via l’Éditeur du Registre

Avertissement : 
Modifier le Registre Windows est une opération périlleuse qui ne doit être réalisée qu’en dernier recours. Faites une sauvegarde du Registre et/ou de l’ordinateur avant de suivre les étapes ci-dessous.
Consultez un spécialiste des systèmes informatiques, si nécessaire.
Esri ne peut pas garantir les résultats suite à des modifications incorrectes qui pourraient survenir en suivant ces consignes. Il est conseillé aux utilisateurs de faire preuve de prudence en gardant à l’esprit qu’ils procèdent à leurs risques et périls.
  1. Lancez le Bloc-notes.
  2. Entrez le texte suivant :
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\arcgis-survey123]
@="URL:arcgis-survey123"
"URL Protocol"=""

[HKEY_CURRENT_USER\Software\Classes\arcgis-survey123\shell]
@="open"

[HKEY_CURRENT_USER\Software\Classes\arcgis-survey123\shell\open]
@=""

[HKEY_CURRENT_USER\Software\Classes\arcgis-survey123\shell\open\command]
@="\"C:\\Users\\\\Applications\\ArcGIS\\Survey123forArcGIS\\Survey123forArcGIS.exe\" \"%1\""
Remarque :
Cette clé de Registre concerne la version 3.2 de Survey123 for ArcGIS et pourrait ne pas s’appliquer à d’autres versions.
Remarque :
La clé « command » doit être mise à jour d’après le chemin d’accès au répertoire d’installation de l’utilisateur concerné. Le chemin utilisateur doit être spécifié sous forme d’un chemin absolu et ne peut pas utiliser une variable d’environnement (par exemple, %USERPROFILE%).
  1. Enregistrez le fichier en tant que fichier .reg.
  2. Exécutez le fichier .reg pour importer les clés dans le Registre. Cliquez sur Oui lorsque Windows vous y invite.

ID d’article:000020276

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet