PROBLÈME

le répertoire de données de secours ne parvient pas à répliquer automatiquement le répertoire de données principal.

Last Published: April 25, 2020

Description

Lorsque vous utilisez ArcGIS Data Store, la machine de secours ne réplique pas automatiquement le répertoire de données principal. De plus, il se peut que la notification « Incomplete startup packet » (paquet de démarrage incomplet) soit renvoyée.

Cause

Aucune communication n’est établie entre le répertoire de données principal et le répertoire de données de secours. Il est possible, par exemple, que les répertoires de données tentent d’établir une connexion l’un avec l’autre via le port 9876, mais que le port ne soit pas disponible.

La notification est souvent renvoyée lorsqu’une machine cliente établit une connexion avec le serveur de base de données, mais n’envoie aucun trafic. La machine cliente vérifie par intermittence si une connexion peut être établie avec le serveur de base de données à l’aide des ports définis.

Solution ou alternative

Supprimez le répertoire de données de secours du site du serveur dans lequel il est hébergé et réinscrivez le répertoire de données de secours.

  1. Supprimez le répertoire de données de secours du site du serveur à l’aide de l’utilitaire removemachine. Pour plus d’informations, reportez-vous à la rubrique Aide de ArcGIS : removemachine.
  2. Arrêtez le service du répertoire de données de secours.
    Remarque :
    Pour démarrer ou arrêter un service de répertoire de données, reportez-vous à Aide de ArcGIS : ArcGIS Data Store - Commandes REST.
  3. Renommez le dossier arcgisdatastore du répertoire de données de secours. Le dossier figure habituellement dans :
    C:\arcgisdatastore
    Ou, si ArcGIS Enterprise Builder a été utilisé pour installer le répertoire de données (disponible à compter de la version 10.5.1) dans :
    C:\arcgis\arcgisdatastore
  4. Démarrez le service du répertoire de données de secours.
  5. Inscrivez le service du répertoire de données de secours auprès du serveur.

ID d’article: 000018651

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement