PROBLÈME

imprimer une carte mise en cache génère une sortie vierge

Last Published: April 25, 2020

Description

La création d’une carte mise en cache améliore les performances de la carte dans laquelle le serveur dessine la carte entière à différentes échelles et stocke des copies des images de carte. La carte mise en cache peut être partagée à l’aide de PrintingTools sur ArcGIS Server. Dans certaines circonstances, lors de l’impression d’une carte mise en cache, le rendu généré est vierge même si la carte mise en cache s’affiche correctement dans les clients d’affichage.

Cause

Par défaut, un service de carte est publié avec les couches dynamiques activées. Lorsque les couches dynamiques sont activées, l’opération d’impression de la tâche Export Web Map (Exporter la carte web) établit une requête dynamique pour créer une sortie dans laquelle les tuiles mises en cache ne sont pas extraites mais pour laquelle une opération d’exportation est réalisée sur les données source. Si, pour une raison quelconque, les données source ne sont pas disponibles, l’opération d’exportation génère un rendu vierge.

Solution ou alternative

Pour résoudre ce problème, désactivez la fonctionnalité des couches dynamiques sur le service de carte. Les couches dynamiques peuvent être désactivées à partir du site ArcGIS Server Manager et dans ArcGIS Desktop.

Pour désactiver les couches dynamiques dans le site ArcGIS Server Manager, reportez-vous à ArcGIS Server : Activation de couches dynamiques dans un service de carte dans le Gestionnaire. Pour désactiver les couches dynamiques dans ArcGIS Desktop, reportez-vous à Aide de ArcMap : Activation de couches dynamiques dans un service de carte dans ArcGIS Desktop.

Remarque :
Lorsque les couches dynamiques sont désactivées, les fonctionnalités des couches à mettre à jour à la volée sont également désactivées.
L’image suivante montre les tuiles extraites et le rendu correctement généré après la désactivation des couches dynamiques.

The tiles are fetched if the dynamic layers are disabled

ID d’article: 000018259

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement