PROBLÈME

échec du service d’impression après la mise à niveau vers ArcGIS Server 10.6.1

Last Published: April 25, 2020

Description

Après la mise à niveau vers ArcGIS Server 10.6.1, toute tentative d’impression à l’aide des services d’impression se solde par un échec. L’examen de l’extrémité REST indique que la tâche intitulée « Export Web Map Task » (Exporter la carte web) n’existe pas. « Export Web Map Task » (Exporter la carte web) est chargé de traiter les données pour délivrer une sortie disponible en téléchargement et, dans le cas présent, pour imprimer. Si la tâche est absente de l’extrémité REST, cela indique que le service d’impression est incapable d’imprimer.

Cause

Ce problème se produit si l’option de mise à niveau du site n’est pas sélectionnée dans la fenêtre du navigateur web à la fin de l’installation de ArcGIS Server.

Solution ou alternative

La solution suivante permet aux utilisateurs de revenir à l’écran du programme d’installation et de sélectionner l’option de mise à niveau du site.

  1. Arrêtez le service ArcGIS Server. Pour savoir comment procéder, reportez-vous à Aide de ArcGIS : Démarrage et arrêt des services.
  2. Accédez au répertoire suivant :
    C:\Program Files\ArcGIS\Server\framework\etc\
  3. Renommez le fichier config-store-connection.xml en config-store-connection-upgrade.xml.
  4. Lancez le service ArcGIS Server.
  5. Sur la machine contenant le service ArcGIS Server, ouvrez un navigateur web et saisissez l’adresse suivant dans la barre d’adresse URL :
    https://localhost:6443/arcgis/manager
    Une invite pour mettre à niveau ArcGIS Server est alors renvoyée.
  6. Procédez à la mise à niveau en veillant à sélectionner l’option de mise à niveau du site.

ID d’article:000019121

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