PROBLÈME

la publication des couches d’entités hébergées échoue sur un portail et retourne l’erreur 001362 et l’erreur 001360

Last Published: April 25, 2020

Description

Lors de la publication de couches d’entités hébergées sur un portail, les erreurs suivantes sont renvoyées :

Erreur : 
Erreur 001362 : L’extraction du manifeste à partir de la définition du service téléchargée a échoué
Erreur : 
Erreur 001360 : L’obtention des métadonnées des éléments de base pour le téléchargement de la définition du service a échoué

Cause

Parmi les causes connues de ces erreurs, on compte notamment les suivantes :

ArcGIS Data Store n’est pas en mesure de communiquer avec ArcGIS Server ou Portal for ArcGIS via les protocoles SSL établis
Les protocoles SSL configurés ou activés pour les machines avec ArcGIS Data Store, Portal for ArcGIS et ArcGIS GIS Server ne sont pas identiques. Toutes les machines doivent avoir les mêmes protocoles SSL pour pouvoir publier les couches d’entités hébergées.

Les outils de publication ne sont pas en mesure de télécharger le fichier de définition du service à partir du portail vers le dossier Temp du compte ArcGIS Server
Lorsqu’une couche d’entités hébergée est publiée, l’outil de publication du serveur d’hébergement télécharge le fichier de définition de service à partir du portail vers le dossier Temp du compte exécutant le service ArcGIS Server sur la machine.

Le téléchargement échoue si :

  • Le compte du service ArcGIS Server ne possède pas les autorisations appropriées pour accéder au dossier.
  • Le lecteur de disque sur lequel se trouve le dossier Temp est saturé.
  • Le dossier Temp contient plus de 65 000 fichiers (cette limite varie selon le système d’exploitation).

Solution ou alternative

Utilisez l’une des solutions suivantes en fonction de la cause :

ArcGIS Data Store n’est pas en mesure de communiquer avec ArcGIS Server ou Portal for ArcGIS via les protocoles SSL établis
  1. Déterminez les protocoles SSL utilisés par ArcGIS Server et Portal for ArcGIS.
    1. Pour connaître le protocole SSL actuellement utilisé par ArcGIS Server, connectez-vous au répertoire d’administration ArcGIS Server (https://..com//admin) en tant qu’administrateur.
    2. Cliquez sur security (sécurité) > config. Notez les versions TLS activées en regard de SSL Protocols (Protocoles SSL).
Remarque :
Les protocoles TLS v1.2 et TLS v1.1 sont les protocoles SSL par défaut du déploiement de base d’ArcGIS Enterprise à compter de la version 10.6.1.
  1. Pour connaître le protocole SSL actuellement utilisé par Portal for ArcGIS, connectez-vous au répertoire d’administration du portail (https://..com//portaladmin) en tant qu’administrateur.
  2. Cliquez sur Security (Sécurité) > SSLCertificates (Certificats SSL). Notez les versions TLS activées, indiquées dans le champ Web Server SSL Protocols (Protocoles SSL du serveur Web).
Remarque :
Assurez-vous que les protocoles ArcGIS Server et Portal for ArcGIS correspondent. Pour plus d’informations sur la configuration des protocoles dans ArcGIS Server et Portal for ArcGIS, reportez-vous à ArcGIS Server : Sécuriser la communication ArcGIS Server (pour ArcGIS Server) et Portal for ArcGIS : Restreindre les protocoles TLS et les suites de chiffrement (pour Portal for ArcGIS).
  1. Activez les protocoles pour chaque machine.
    1. Sur la machine ArcGIS Server, ouvrez l’application Services à partir du menu Démarrer de Windows.
Remarque :
Il est possible de rechercher l’application Services à partir du menu Démarrer de Windows ou en saisissant services.msc dans la boîte de dialogue Démarrer > Exécuter et en appuyant sur la touche Entrée.
  1. Notez le propriétaire du service ArcGIS Server figurant dans la colonne Ouvrir une session en tant que.
  1. Connectez-vous à la machine ArcGIS Server via le compte exécutant le service ArcGIS Server.
  2. Dans le menu Démarrer de Windows, recherchez Options Internet et cliquez dessus.
  3. Dans l’onglet Avancé, accédez à la section Paramètres et vérifiez si les protocoles correspondent à ceux de l’étape 1.
Remarque :
Il se peut que vous deviez consulter le service informatique pour savoir s’il faut modifier ces protocoles.
  1. Recommencez les étapes a à e pour les machines sur lesquelles Portal for ArcGIS et ArcGIS Data Store sont installés.
Les outils de publication ne sont pas en mesure de télécharger le fichier de définition du service à partir du portail vers le dossier Temp du compte ArcGIS Server
  1. Accordez au compte ArcGIS Server le contrôle total sur son dossier Temp.
    1. Sur la machine ArcGIS Server, ouvrez l’application Services à partir du menu Démarrer de Windows.
    2. Notez le propriétaire du service ArcGIS Server figurant dans la colonne Ouvrir une session en tant que.
    3. Connectez-vous à la machine ArcGIS Server via le compte exécutant le service ArcGIS Server.
    4. Dans l’Explorateur de fichiers Windows, accédez au dossier Temp.
Remarque :
Le dossier temporaire se trouve par défaut à l’emplacement C:\Users\Default\AppData\Local.
  1. Cliquez avec le bouton droit sur le dossier et cliquez sur Propriétés > Sécurité.
  2. Mettez en surbrillance le compte de service ArcGIS Server et cochez la case en regard de Contrôle total sous Autorisations pour. Cliquez sur Apply (Appliquer).
  1. Vérifiez l’espace disque disponible sur le lecteur de disque sur lequel se trouve le dossier Temp du compte de service ArcGIS Server.
    1. Dans l’Explorateur de fichiers Windows, cliquez avec le bouton droit sur le lecteur sur lequel se trouve le dossier Temp (il s’agit généralement du lecteur C). Cliquez sur Propriétés.
    2. Vérifiez la quantité d’espace libre. Si l’espace libre est faible ou inexistant, cliquez sur le bouton Nettoyage de disque pour effacer les fichiers superflus.
  1. Effacez les fichiers stockés dans le dossier Temp.
    1. Accédez au dossier Temp. Cliquez avec le bouton droit sur le dossier Temp, puis cliquez sur Propriétés.
    2. Sous l’onglet Général, vérifiez le nombre de fichiers trouvés. Si ce nombre dépasse les limites du système d’exploitation, supprimez les fichiers inutiles.

ID d’article: 000019726

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