PROBLÈME

les domaines n’apparaissent pas dans Collector for ArcGIS après la modification d’un service d’entités hébergé dans ArcGIS Online

Last Published: April 25, 2020

Description

Après la modification ou l’ajout d’un domaine à la structure d’un service d’entités hébergé dans ArcGIS Online, les domaines n’apparaissent pas dans Collector for ArcGIS.

Cause

Les domaines ne figurent pas dans Collector for ArcGIS pour les raisons suivantes :

  • Le domaine n’a pas été ajouté à la section template du JSON (JavaScript Object Notation) lors de la modification du domaine dans ArcGIS Online.
  • Lorsqu’une carte est utilisée en mode hors connexion, un réplica de la géodatabase de chaque couche d’entités est téléchargé sur le périphérique avec Collector for ArcGIS. Collector for ArcGIS utilise un réplica plus ancien de la carte Web lorsque la structure du service d’entités est modifiée et à nouveau publiée dans ArcGIS Online.

Solution ou alternative

Si les domaines du service d’entités hébergé sont ajoutés à la structure dans ArcGIS Online, assurez-vous qu’ils sont également mis à jour dans la section Template de la structure.

Pour ajouter un domaine sous la section Template du JSON lorsque vous mettez ce dernier à jour dans un éditeur JSON, procédez comme suit :
  1. Recherchez « template » dans le JSON.
  2. Ajoutez le code suivant :
"domains": {
    "status": {"type": ""}
   },
Vous pouvez également télécharger à nouveau la carte Web dans Collector for ArcGIS après que des modifications sont apportées à la structure du service d’entités hébergé dans ArcGIS Online.
Remarque :
Pour vous assurer qu’aucune donnée collectée par d’autres utilisateurs avec Collector for ArcGIS n’est perdue, chargez les données avant de modifier la structure du service d’entités.

ID d’article:000014011

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

En savoir plus sur ce sujet