PROBLÈME

ArcGIS Pro reste figé après la connexion

Last Published: September 22, 2020

Description

La boîte de dialogue Sign In (Connexion) d’ArcGIS Pro se fige, entraînant ainsi l’échec des tentatives de connexion, ce qui peut générer des erreurs liées à la certification, aux licences ou à un nom d’utilisateur non valide.

Cause

L’entrée de registre d’ArcGIS Pro est corrompue. Cela peut se produire si plusieurs versions d’ArcGIS for Desktop sont installées sur le même ordinateur et que les paramètres de variable d’environnement dans le registre du système d’exploitation sont modifiés en conséquence.

Solution ou alternative

Les solutions de contournement suivantes sont possibles pour ce problème.
Remarque :
Avant de commencer, vérifiez qu’une licences ArcGIS Pro active est allouée. Le document d’aide ArcGIS Online Help suivant indique comment procéder : Gérer les licences.
Solution de contournement 1 : renommez les dossiers ArcGIS Pro
Remarque :
Le dossier AppData est un dossier masqué. Le document suivant du support Microsoft indique comment afficher les fichiers masqués : Show hidden files (Afficher les fichiers masqués)
  1. Accédez aux emplacements suivants :
    • C:\Users\\AppData\Roaming\ESRI et
    • C:\Users\\AppData\Local\ESRI
  2. Renommez le dossier ArcGISpro en ArcGISpro_old.
Remarque :
Le fait de renommer le dossier ArcGISpro entraîne la réinitialisation d’ArcGIS Pro. Lancez ArcGIS Pro pour recréer le dossier ArcGIS Pro.
  1. Redémarrez l’ordinateur ArcGIS Pro.
  2. Ouvrez ArcGIS Pro.
  3. Connectez-vous à ArcGIS Pro et vérifiez que la connexion aboutit.
Solution de contournement 2 : renommez le dossier FLEXnet
Remarque :
Le dossier ProgramData est un dossier masqué.
  1. Accédez à C:\ProgramData\FLEXnet.
  2. Renommez le dossier FLEXnet en FLEXnet_old.
Remarque :
Le fait de renommer le dossier FLEXnet entraîne la réinitialisation de FLEXnet. Lancez ArcGIS Pro pour recréer le dossier FLEXnet.
  1. Redémarrez l’ordinateur ArcGIS Pro.
  2. Ouvrez ArcGIS Pro.
  3. Connectez-vous à ArcGIS Pro et vérifiez que la connexion aboutit.
Solution de contournement 3 : supprimez les clés de registre
Avertissement : 
Les instructions ci-après impliquent de modifier des parties essentielles de votre système d’exploitation. Il est recommandé de sauvegarder votre système d’exploitation et vos fichiers, y compris le registre, avant de continuer. Consultez un spécialiste des systèmes informatiques, si nécessaire. Esri ne peut pas garantir les résultats suite à des modifications incorrectes qui pourraient survenir en suivant ces consignes. Par conséquent, soyez prudent et continuez à vos propres risques.
  1. Accédez à Windows Démarrer et entrez regedit dans la barre de recherche Rechercher les programmes et fichiers.
  2. Ouvrez l’Editeur du Registre avec un compte administrateur.
Image shows the regedit icon
  1. Supprimez les sous-clés de registre suivantes de la ruche HKEY_CURRENT_USER :
  • HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online for Pro
  • HKEY_CURRENT_USER\Software\ESRI\ArcGISPro
  • HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online
  • HKEY_CURRENT_USER\Software\ESRI\ArcGISPro1.0
  1. Redémarrez l’ordinateur ArcGIS Pro.
  2. Ouvrez ArcGIS Pro.
  3. Connectez-vous à ArcGIS Pro et vérifiez que la connexion aboutit.

ID d’article: 000013863

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