Description
Après l’installation du paquetage Python d’ArcGIS, ArcGIS Pro se bloque lors des tentatives d’utilisation de la fenêtre Python, ou parfois, lors de l’ouverture d’un projet.
Cause
Certains rapports liés à ArcGIS Pro 1.4.1 indiquent un blocage après l’installation de paquetages ; cela dépend des paquetages Jupyter/pyQT installés via Conda. Cet incident est dû à une DLL problématique fournie avec Conda qui ne répond pas aux critères de la PEP 384.
Solution de contournement
Pour résoudre facilement ce problème, il suffit de supprimer ou de renommer la DLL en cause dans le dossier de l’environnement ArcGIS Pro actif. Dans le dossier %ProInstalDir%/bin/Python/envs/arcgispro-py3 (ou équivalent, si des environnements supplémentaires ont été créés), supprimez ou renommez Python3.dll.
La plupart des utilisateurs sont réticents à l’idée de modifier les fichiers DLL, mais le fichier Python35.dll, censé être chargé et qui résout ce problème, figure dans ce dossier. Une fois Python3.dll supprimé, ouvrez à nouveau ArcGIS Pro qui devrait alors fonctionner comme prévu. Ce problème a été identifié et résolu dans ArcGIS Pro 2.0.