ERREUR

L’ID utilisateur [userID] ne correspond à aucun utilisateur nommé dans votre organisation et est actif dans votre projet. Reportez-vous aux informations indiquant comment supprimer un utilisateur d’un projet

Last Published: September 30, 2022

Message d’erreur

Lorsqu’un administrateur tente de supprimer un utilisateur ayant le rôle d’opérateur de terrain à partir d’un projet Workforce for ArcGIS, le message d’erreur suivant est renvoyé :

Erreur : 
L’ID utilisateur [userID] ne correspond à aucun utilisateur nommé dans votre organisation et est actif dans votre projet. Reportez-vous aux informations indiquant comment supprimer un utilisateur d’un projet.

Dans l’onglet USERS, l’ID utilisateur de l’opérateur de terrain n’est pas valide, mais le rôle apparaît comme « Actif » dans l’application Workforce for ArcGIS. Lorsque vous cliquez sur l’onglet USERS, il arrive parfois que le contenu soit vide. Les images ci-dessous montrent le message d’erreur avec l’ID utilisateur non valide et le contenu vide.
Image with error message

Image with blank content

Cause

Ce problème se produit si l’utilisateur doté du rôle d’opérateur de terrain a démarré ou terminé des affectations de travail qui lui ont été confiées dans le cadre d’un projet ou que l’affectation est en cours.

Solution ou alternative


Pour supprimer des utilisateurs jouant le rôle d’opérateurs de terrain dans l’application Workforce for ArcGIS, utilisez l’une des solutions suivantes :

Pour les affectations non débutées ou non terminées
Réattribuez l’affectation à un autre utilisateur doté du rôle d’opérateur de terrain et supprimez l’utilisateur précédent dans l’application Workforce for ArcGIS. Pour en savoir plus, reportez-vous à la section Aide Web de Workforce for ArcGIS : Réattribuer des affectations.

Pour les affectations en cours ou terminées
Réattribuez l’affectation au niveau du service d’entités dans ArcGIS Online. Suivez les instructions décrites ci-après :

  1. Dans ArcGIS Online, cliquez sur Content (Contenu) > My Content (Mes contenus) et accédez à Folders (Dossiers).

    Content and My Content pane
     
  2. Cliquez sur le dossier contenant l’affectation Workforce for ArcGIS désirée et cliquez sur la couche d’entités de l’opérateur.

    Folder and worker feature layer pane
     
  3. Cliquez sur Data (Données) > Table et cliquez sur le bouton Options. Sélectionnez Show/Hide Columns (Afficher/masquer les colonnes).

    Data and table pane with the option button
     
  4. Cochez la case ObjectID. Identifiez l’ObjectID de l’utilisateur précédent à supprimer ainsi que du nouvel utilisateur auquel l’affectation doit être réattribuée.

    ObjectID check box
    ObjectID of users
Remarque :
Les opérateurs sont identifiés par un ObjectID. L’ObjectID permet de modifier le WorkerID de l’affectation.
  1. Ouvrez la couche de l’affectation dans Map Viewer et remplacez le WorkerID associée à l’affectation par l’ID du nouvel utilisateur :
    1. Ouvrez l’affectation dans Map Viewer et dans la fenêtre Contents (Contenu), cliquez sur Show Table (Afficher la table).

      Contents pane
       
    2. Dans la table, double-cliquez sur le WorkerID associé à l’affectation à modifier et remplacez l’ObjectID par l’ID du nouvel opérateur de terrain, puis cliquez sur Save (Enregistrer).

      Table with WorkerID
       
  2. Ouvrez Workforce for ArcGIS et supprimez l’utilisateur précédent.

ID d’article: 000019491

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement