ERREUR

groupe d’administration Hub manquant

Last Published: May 10, 2022

Message d’erreur

Après la mise à niveau vers ArcGIS Enterprise version 10.6.x et la configuration de l’application ArcGIS Enterprise Sites pour le partage de données avec vos followers, le message d’erreur suivant est renvoyé lors de l’accès au site de l’administrateur (https:///webadaptor/apps/site/admin) :

Erreur : 
Groupe d’administration Hub manquant

Error: Missing Hub Administration Group

Cause

Lorsque l’application ArcGIS Enterprise Sites est activée et configurée, un groupe d’administration de site associé à tout site de Portal for ArcGIS et un élément d’application Sites sont créés. Le site et l’élément d’application Site appartiennent à l’administrateur du site. Le fait de cliquer sur le lanceur de l’application ArcGIS Enterprise Sites redirige l’utilisateur vers la page d’administration. En cas de suppression du groupe d’administration de site, après que vous avez ignoré les messages d’interdiction de suppression et supprimé la protection contre la suppression, ce message d’erreur est renvoyé.

Solution ou alternative

Pour résoudre ce problème, récupérez le contenu partagé sur l’application Sites à partir d’un groupe ArcGIS Enterprise supprimé en créant un nouveau groupe d’administration.

  1. Dans Portal for ArcGIS, accédez à Groups (Groupes).
  2. Créez un nouveau groupe avec les paramètres suivants :
    • Group Name (Nom du groupe) :
    • Summary (Description) :
    • Tags (Balises) : siteCollaboration
    • Who can view this group (Qui peut afficher ce groupe) : People in the organization (Membres de l’organisation)
    • Who can join this group (Qui peut rejoindre ce groupe) : Those who request membership and are approved by a group manager (Personnes demandant à adhérer et approuvées par un gestionnaire de groupe)
    • Who can contribute content to the group (Qui peut contribuer au contenu du groupe) : Group Members (Membres du groupe)
    • What items in the group can its members update (Quels éléments du groupe ses membres peuvent-ils mettre à jour) : All items (Tous les éléments)

      Group Details page
  3. Copiez l’ID du groupe et ajoutez-le aux propriétés du portail.

    Group ID
     
  4. Connectez-vous au point d’extrémité sharing/rest endpoint.
    https:///webadaptor/sharing/rest
  5. Accédez à Home > Portal > Self (Accueil > Portail > Auto).
  6. Faites défiler la page jusqu’en bas et cliquez sur Update (Mettre à jour).
  7. Dans les propriétés du portail, remplacez l’ID du groupe par le nouvel ID, puis cliquez sur Update (Mettre à jour).

    Replace Group ID
     
  8. Identifiez l’ID de l’application Sites.

    Site application ID.
     
  9. Accédez au point d’extrémité sharing/rest et cliquez sur User Content (Contenu utilisateur) > Siteapplication pour l’ID.
  10. Remplacez collaborationGroupId par l’ID du nouveau groupe.

    Collaboration group ID.
     
  11. Accédez à la page de contenu du portail et partagez l’application cartographique Web ArcGIS Enterprise Sites et l’élément d’application Sites avec le nouveau groupe. Sélectionnez Access and Update Capabilities (Fonctions d’accès et de mise à jour) de sorte que le nouveau groupe apparaisse dans les options.
     

    Si le groupe ArcGIS Enterprise Sites, le lanceur de l’application Sites, l’application cartographique Web et l’élément d’application Sites sont supprimés, le processus suivant réinitialise tout le jeu de données :

    Remarque :
    Agissez avec précaution. Ce processus constitue le dernier recours, car il est impossible de récupérer le contenu partagé sur le site.
    1. Connectez-vous au point d’extrémité sharing/rest (https://machine.domaine.com/webadaptor/sharing/rest).
    2. Accédez à Home > Portal > Self (Accueil > Portail > Auto).
    3. Faites défiler la page jusqu’en bas et cliquez sur Update (Mettre à jour).
    4. Mettez en surbrillance et supprimez le texte ci-dessous dans les propriétés du portail.
      "openData" {"enabled":true,"settings" {"groupId":"alphanumericID","appVersion":"2.1"}}}
    5. Cliquez sur Update Organization (Mettre à jour l’organisation). L’application Sites est réinitialisée et les applications et le contenu associés sont perdus.
    6. Reconstruisez l’application ArcGIS Enterprise Sites.

ID d’article:000019069

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement