ERREUR

ArcGISIndexingServer ne fonctionne plus

Last Published: April 25, 2020

Message d’erreur

Lorsque ArcGIS Pro est installé, les utilisateurs peuvent rencontrer l’erreur suivante :

Erreur :
ArcGISIndexingServer ne fonctionne plus
Screenshot of the error.

Cette erreur peut se produire de manière aléatoire, même lorsque ArcGIS Pro n’est pas en cours d’exécution.

Cause

Par défaut, ArcGIS Pro crée automatiquement et met à jour de manière dynamique un index consultable à mesure que les utilisateurs utilisent des projets. Des éléments, tels que les connexions aux dossiers, bases de données et boîtes à outils, sont mis à jour dans l’index lors de leur ajout au projet. Pour plus d’informations sur les éléments, reportez-vous à la rubrique suivante : Types de données et éléments pris en charge.

Selon la taille du projet et la quantité d’éléments indexés, la taille de l’index peut dépasser la mémoire disponible, ce qui déclenche une erreur.

Solution ou alternative

Pour éviter cette erreur, supprimez l’index existant ou désactivez l’indexation en procédant de l’une des manières suivantes. Certaines méthodes impliquent la modification des paramètres Windows, ce qui nécessite de sauvegarder le système d’exploitation et les fichiers.

  • Supprimer l’index
  1. Dans le menu Project (Projet), ouvrez la boîte de dialogue Options.
  2. Cliquez sur l’onglet Indexing (Indexation).
  3. Cliquez sur Delete Index (Supprimer l’index).
  4. Cliquez sur OK.
  • Désactiver l’indexation
Avertissement :
Les instructions ci-après impliquent de modifier des parties essentielles de votre système d’exploitation. Il est recommandé de sauvegarder le système d’exploitation et les fichiers, y compris le Registre, avant de continuer. Consultez un spécialiste des systèmes informatiques, si nécessaire.

Esri ne peut pas garantir les résultats suite à des modifications incorrectes qui pourraient survenir en suivant ces consignes. Par conséquent, soyez prudent et continuez à vos propres risques.
  1. Dans le menu Project (Projet), ouvrez la boîte de dialogue Options.
  2. Cliquez sur l’onglet Indexing (Indexation).
  3. Sous Configure if the index is created and how it is used (Configurer la création de l’index et son utilisation), cliquez sur Don't create an index (Ne pas créer d’index).
  4. Cliquez sur OK.
  • Désactiver ArcGISIndexingServer.exe dans Windows 7
Remarque :
Pour obtenir des instructions concernant les versions les plus récentes des Windows, consultez la documentation d’aide de Microsoft.
  1. Cliquez sur le bouton Start (Démarrer).
  2. Cliquez sur Control Panel (Panneau de configuration) > System and Maintenance (Système et maintenance) > Administrative Tools (Outils d’administration).
  3. Double-cliquez sur Task Scheduler (Planificateur de tâches).
  4. Cliquez sur Task Scheduler Library (Bibliothèque du Planificateur de tâches) et sélectionnez ArcGIS Pro Indexing (Indexation de ArcGIS Pro).
  5. Dans la fenêtre Actions, cliquez sur Disable (Désactiver).
  • Renommer le dossier Index
    Renommez le dossier Index dans Windows afin que ArcGIS Pro génère un nouveau dossier d’indexation.
  1. Ouvrez l’Explorateur Windows et accédez à C:\Users\\AppData\Local\ESRI\.
  2. Renommez le dossier Index.

ID d’article: 000016984

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Informations associées

En savoir plus sur ce sujet

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement