PROBLEMA

No se puede iniciar sesión ni crear cuentas nuevas en Portal for ArcGIS

Last Published: October 14, 2021

Descripción

En algunos casos, los intentos de iniciar sesión en Portal for ArcGIS por primera vez fallan y no es posible crear nuevas cuentas de usuario. Si la cuenta no se crea automáticamente después de iniciar sesión, los usuarios específicos de la organización pueden acceder al portal, aunque solo con los privilegios de un usuario sin una cuenta de organización de ArcGIS.

Causa

  • El ajuste 'enableAutomaticAccountCreation' se establece en 'false'.
  • ArcGIS Web Adaptor no está configurado correctamente. Por ejemplo, la opción 'Autenticación de Windows' está deshabilitada en el Administrador de Internet Information Server (IIS).

Solución o solución alternativa

En función de la causa, utilice una de las siguientes opciones para resolver el problema.

Establezca el ajuste enableAutomaticAccountCreation como 'true'

  1. Inicie sesión en Portaladmin API con una cuenta de administrador. Por ejemplo:
https://portal.domain.com:7443/<web adaptor name>/portaladmin
  1. Seleccione Seguridad > Configuración > Actualizar configuración de seguridad.
  2. Edite la configuración enableAutomaticAccountCreation para que se lea: true.
  3. Haga clic en Actualizar configuración.
La página Actualizar configuración de seguridad con la configuración enableAutomaticAccountCreation establecida en 'true'.

Configurar adecuadamente ArcGIS Web Adaptor

Configure correctamente ArcGIS Web Adaptor en el Administrador de Internet Information Server (IIS). Para ver los pasos, consulte Portal for ArcGIS: Configurar ArcGIS Web Adaptor para usar IWA.

Id. de artículo:000026600

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema