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Error: No se puede iniciar sesión usando IDP. Se encontró un asunto no válido en la respuesta SAML para Shibboleth

Mensaje de error

Cuando se utiliza el IDP de Shibboleth, aparece el siguiente error al intentar iniciar sesión en un portal de ArcGIS Enterprise mediante inicios de sesión SAML:

No se puede iniciar sesión con Idp. Se encontró un asunto no válido en la respuesta SAML.

Causa

El atributo SAML NameID no se encuentra en el elemento <Subject> de la respuesta de la aserción SAML.

Solución o solución alternativa

  1. Edite el archivo SHIBBOLETH_HOME/conf/saml-nameid.xml y reemplace esta sección:
<!-- <bean parent="shibboleth.SAML2AttributeSourcedGenerator"    p:format="urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress"    p:attributeSourceIds="#{ {'mail'} }" /> --> con lo siguiente: <bean parent="shibboleth.SAML2AttributeSourcedGenerator"             p:format="urn:oasis:names:tc:SAML:1.1:nameid-format:unspecified"             p:attributeSourceIds="#{ {'your-name-id-attribute'} }" />
  1. Reinicie el servicio (Windows) o el demonio de Shibboleth (Linux).

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Última modificación: 7/22/2021

Id. de artículo: 000026099

Software: Portal for ArcGIS 10.9, 10.8.1, 10.8, 10.7.1, 10.7