PROBLEMA

ArcGIS Pro deja de funcionar al iniciarse cuando se instala con App Layering y se agrega a Citrix XenDesktop o XenApps

Last Published: September 15, 2020

Descripción

Al utilizar App Layering para agregar ArcGIS Pro a una versión compatible de Citrix XenDesktop o XenApps, la aplicación puede fallar al iniciarse si la ejecuta un usuario con acceso no administrativo. Un usuario con acceso administrativo no experimenta el error en el mismo entorno. Si se instala en XenDesktop o XenApps sin App Layering, ArcGIS Pro no se bloquea, ni siquiera por un usuario sin permisos elevados.

Causa

Cuando se utiliza App Layering para instalar ArcGIS Pro y se agrega a XenDesktop o XenApp, se requiere permiso adicional para acceder al FlexNet Licensing Service.

Solución o solución alternativa

Además de instalar ArcGIS Pro utilizando App Layering, el administrador también debe ejecutar una instalación de línea de comandos del FlexNet Licensing Service con el parámetro MODIFYFLEXDACL=TRUE. Por ejemplo:

msiexec /I "C:\Archivos de programa\ArcGIS\Pro\Resources\ArcGIS Licensing Service\ArcGISLS.msi" MODIFYFLEXDACL=TRUE

Id. de artículo:000023466

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Descubrir más sobre este tema