PROBLEMA

Error 404 al iniciar sesión en Survey123 for ArcGIS a través de Portal for ArcGIS

Last Published: May 18, 2022

Descripción

Al iniciar sesión en Survey123 for ArcGIS a través del selector de aplicaciones o el sitio web de Portal for ArcGIS, aparece un error 404 que indica que no se encuentra la página.

Imagen del mensaje de error

Causa

La URL de Survey123 for ArcGIS configurada para el selector de aplicaciones o sitio web es incorrecta. En la mayoría de los casos, esto se debe a que la URL incluye el directorio '/home', ya que es la página de acceso predeterminada para la mayoría de usuarios de Portal for ArcGIS.

Al iniciar sesión en Portal for ArcGIS en el sitio web de Survey123 for ArcGIS, el esquema de URL correcto es:

https://survey123.arcgis.com/?portalUrl=https://webadaptorhost.domain.com/webadaptor

Al iniciar sesión, la solicitud utiliza la URL de Portal for ArcGIS proporcionada con lo siguiente incorporado:

/sharing/rest/oauth2/authorize?client_id=survey123hub&display=default&redirect_uri=https%3A%2F%2Fsurvey123.arcgis.com%2Fsurveys%3FportalUrl%3Dhttps%3A%252F%252Fwddhsgisl02.dhs.sdc.pvt%252Fportal%252Fhome%252F&parent=https://survey123.arcgis.com&locale=en&response_type=token&expiration=720

El siguiente es un ejemplo de una solicitud correcta, utilizando la URL de Portal for ArcGIS proporcionada sin el directorio '/home':

https://webadaptorhost.domain.com/webadaptor/sharing/rest/oauth2/authorize?client_id=survey123hub&display=default&redirect_uri=https%3A%2F%2Fsurvey123.arcgis.com%2Fsurveys%3FportalUrl%3Dhttps%3A%252F%252Fwddhsgisl02.dhs.sdc.pvt%252Fportal%252Fhome%252F&parent=https://survey123.arcgis.com&locale=en&response_type=token&expiration=720

A continuación, se muestra una solicitud incorrecta, utilizando la URL de Portal for ArcGIS proporcionada con el directorio '/home':

https://webadaptorhost.domain.com/webadaptor/home/sharing/rest/oauth2/authorize?client_id=survey123hub&display=default&redirect_uri=https%3A%2F%2Fsurvey123.arcgis.com%2Fsurveys%3FportalUrl%3Dhttps%3A%252F%252Fwddhsgisl02.dhs.sdc.pvt%252Fportal%252Fhome%252F&parent=https://survey123.arcgis.com&locale=en&response_type=token&expiration=720

Solución o solución alternativa

Elimine el directorio '/home' de la URL de Portal for ArcGIS e inicie sesión de nuevo.

Id. de artículo:000023188

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema