PROBLEMA

La replicación en una implementación en espera de ArcGIS Enterprise 10.8 no funciona en Microsoft Azure

Last Published: April 25, 2020

Descripción

La ejecución de la utilidad webgisdr en Microsoft Azure para replicar ArcGIS Enterprise 10.8 en una implementación de la versión 2 (V2) en espera con el fin de proporcionar redundancia geográfica no funciona sin nuevos pasos de preparación.

Causa

Una entrada en el archivo etc\hosts puede ayudar a dirigir las solicitudes a la implementación en espera a través de las URL públicas de ArcGIS Enterprise. Debido a los cambios de configuración correspondientes a las implementaciones V2 en Microsoft Azure 10.8 para implementaciones de ArcGIS Enterprise en Microsoft Azure, no existe ningún modo de dirigir las solicitudes al entorno en espera durante una restauración utilizando una entrada etc\hosts. Se requieren pasos manuales para restaurar ArcGIS Enterprise 10.8 V2 en una implementación en espera al aprovechar la redundancia geográfica como opción de recuperación de desastres.

Solución o solución alternativa

Complete estos pasos antes de restaurar una copia de seguridad creada a partir de la implementación V2 principal. Estos pasos garantizan que las solicitudes a la implementación en espera durante la operación de restauración se dirijan a los equipos de la implementación en espera. No necesita completar estos pasos para implementaciones V1, aunque las actualice a ArcGIS 10.8.

 

Actualizar URL de Portal for ArcGIS

  1. En la máquina virtual del portal de la implementación de ArcGIS Enterprise en espera en Azure, abra un navegador web e inicie sesión en el directorio del portal de ArcGIS como miembro del rol de administrador predeterminado de la organización del portal. La URL del directorio del portal de ArcGIS tiene el siguiente formato:
https://portal.domain.com:7443/arcgis/portaladmin

Si la implementación de ArcGIS Enterprise en espera tiene alta disponibilidad, puede abrir el navegador web en el equipo principal o en espera.

  1. Haga clic en Sistema > Propiedades > Actualizar propiedades.
  2. En el cuadro de diálogo Actualizar propiedades del sistema, actualice la propiedad privatePortalURL para señalar el portal principal; por ejemplo:
https://primary.domain.com:7443/arcgis
  1. Haga clic en Actualizar propiedades para aplicar los cambios.
  2. Inicie sesión en el extremo REST de Portal for ArcGIS (con el formato https://portal.domain.com:7443/arcgis/sharing/rest) como miembro del rol de administrador predeterminado para actualizar la información del servidor de alojamiento.
  3. Desde la página de inicio del extremo REST de Portal for ArcGIS, abra Portales > Auto > Servidores y haga clic en el Id. de servidor del servidor de alojamiento de su portal.
  4. Haga clic en Actualizar servidor y escriba o pegue la URL de uno de los equipos servidores del sitio del servidor de alojamiento en el parámetro URL del servidor admin . La URL presenta el siguiente formato:
https://server.domain.com:6443/arcgis
  1. Haga clic en Actualizar para aplicar los cambios.
  2. Realice este cambio en cada servidor federado de la implementación de ArcGIS Enterprise mediante el uso de la URL de admin de uno de los equipos del sitio.
  3. Valide sus servidores federados con el directorio del portal de ArcGIS. La URL tiene el formato:
https://portal.domain.com:7443/arcgis/portaladmin
  1. Inicie sesión como miembro del rol de administrador predeterminado y vaya a Federación > Servidores. Valide cada uno de los sitios de servidor federado.

Actualizar URL de ArcGIS Server
Repita los pasos siguientes para el servidor de alojamiento y para cada servidor federado de la implementación de ArcGIS Enterprise, incluidos los sitios de ArcGIS Notebook Server, ArcGIS GeoEvent Server, GeoAnalytics Server, análisis de ráster, servidores de alojamiento de imágenes o servidores SIG que están federados con la implementación.

  1. Inicie sesión en el directorio del administrador de ArcGIS Server como administrador del sitio principal; también puede generar y proporcionar un token de administrador de Portal for ArcGIS. La URL del directorio del administrador de ArcGIS Server tiene el formato siguiente:
https://server.domain.com:6443/arcgis/admin
  1. Haga clic en Seguridad > Config y asegúrese de que la propiedad privatePortalURL hace referencia al cambio efectuado en el paso 3 anterior. Si no es así, realice los pasos 3 y 4 a continuación.
  2. En la página Seguridad > Config, haga clic en Actualizar y sustituya el valor de privatePortalURL, que debería hacer referencia al nombre del dominio totalmente calificado del sitio, a la URL interna establecida en el paso 3 de la sección anterior.
  3. Haga clic en Actualizar para aplicar los cambios al sitio de este servidor federado.

La configuración anterior debe definirse antes de restaurar una copia de seguridad en la implementación en espera. Si promociona la implementación en espera como implementación principal, revierta los cambios. Realice los pasos anteriores, pero:

  • En el primer procedimiento (Actualizar URL de Portal for ArcGIS, paso 3), defina privateportalURL en el nombre del dominio totalmente calificado que se utiliza para acceder al portal, en lugar de la URL del equipo interno. Coincidirá con la propiedad WebContextURL .
  • En el paso 7, defina la URL del administrador del servidor en el nombre del dominio totalmente calificado que se utiliza para acceder al sitio de ArcGIS Server. Coincidirá con la propiedad WebContextURL del sitio en Directorio de administrador de ArcGIS Server > Sistema > Propiedades.
  • En el paso 2 del segundo procedimiento ( Actualizar URL de ArcGIS Server), si la propiedad privatePortalURL de la página Seguridad > Config de ArcGIS Server no coincide con lo que se ha introducido en el paso 3 del primer procedimiento (Actualizar URL de Portal for ArcGIS), sustituya el valor existente por el nombre de dominio totalmente calificado que se emplea para acceder al sitio de ArcGIS Server.

Si continúa teniendo este problema después de realizar estos pasos, contacte con el soporte técnico de Esri (para clientes de Estados Unidos) o con su distribuidor de Esri (para clientes de fuera de Estados Unidos) para solucionarlo.

 

Id. de artículo:000022541

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Descubrir más sobre este tema