PROBLEMA

Dataset no encontrado al publicar encuestas en Portal for ArcGIS

Last Published: April 27, 2022

Descripción

El intento de publicar encuestas de ArcGIS Survey123 Connect o ArcGIS Survey123 en Portal for ArcGIS genera los siguientes mensajes de error:

Error: Dataset no encontrado. Estado: Error. Detalles: código 500
Error: Error al obtener el parámetro resultante. Estado: Error. Detalles: código 500
Error: No se puede crear una nueva encuesta. ERROR: Dataset no encontrado.
El mensaje de error en ArcGIS Survey123

Causa

Los mensajes de error generados indican un problema más amplio. Las posibles causas de este error incluyen, entre otras:

  • Portal for ArcGIS no puede crear capas de entidades alojadas, lo que constituye una parte fundamental del proceso de publicación.
  • Los servicios de geoprocesamiento PublishingTools o PublishingToolsEx no se están ejecutando o se deben reiniciar.
  • La licencia de ArcGIS Data Store ha caducado.
  • ArcGIS Data Store no está validado en ArcGIS Server.
  • El usuario no tiene permisos asignados para publicar servicios de entidades alojados en ArcGIS Server.
  • El formulario de Survey123 publicado en Portal for ArcGIS solo contiene una pregunta de geopunto con la columna personalizada bind::esri:fieldType establecida en null. Consulte BUG-000137465 para obtener más información.

Solución o solución alternativa

  1. Revise Portal for ArcGIS para asegurarse de que puede publicar capas de entidades alojadas. Para probar que es posible, cree una capa con Portal for ArcGIS, ya sea por medio de una plantilla o cargando un archivo CSV directamente.
Nota: Si no se devuelve el error con todos los formularios de encuesta, puede tratarse de un problema de configuración o una cuestión relacionada con el diseño XLSForm de la encuesta. Vuelva a publicar el formulario de encuesta o consulte ArcGIS Survey123: Conceptos básicos de XLSForm para conocer las prácticas recomendadas en lo que respecta al diseño XLSForm.
  1. Si el error continúa, compruebe el estado de los servicios de geoprocesamiento PublishingTools o PublishignToolsEx. Consulte ArcGIS Server: Iniciar y detener servicios para obtener más información.
  2. Compruebe los registros de ArcGIS Server Manager para identificar la causa subyacente. Consulte los pasos para acceder a los registros en ArcGIS Server: Registros de servidor.
    1. Ejecute la utilidad describedatastore.bat. Consulte ArcGIS Enterprise: Referencia de utilidades de comandos de ArcGIS Data Store para obtener más información sobre las referencias de utilidades de comandos de ArcGIS Data Store.
    2. Compruebe el modo de data store y el espacio libre en disco. Si el modo de data store se configura en READONLY y hay espacio en disco disponible, utilice el comando siguiente para configurar el data store relacional en READWRITE.
changedatastoremode readonly|readwrite [--prompt <yes|no>]
Nota: El modo de data store se configura automáticamente en READONLY cuando hay poco espacio en disco en el equipo, con el fin de evitar la pérdida de datos.
  1. Reinicie el servicio de ArcGIS Data Store en Windows.
Símbolo del sistema para describedatastore.bat

Id. de artículo:000022129

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema