Español

Cómo: Configurar Windows para usar TLS 1.2 para ArcGIS Desktop

Resumen

Nota:
Esta es una solución opcional para configurar ArcGIS Desktop para que utilice TLS 1.2. Para ver una descripción del resto de opciones, incluida la recomendada, consulte Preguntas frecuentes: ¿Cómo puedo habilitar TLS 1.2 en ArcGIS Desktop?

Como parte de la mejora de la seguridad de ArcGIS Online, Esri exige las conexiones TLS 1.2 para los servicios de ArcGIS Online. Se deben tomar medidas para garantizar el acceso a estos servicios.

Los métodos que aparecen a continuación describen cómo configurar el sistema operativo Windows para que utilice TLS 1.2. Con ello se habilita que todas las aplicaciones del sistema que dependen de Microsoft .NET Framework utilicen TLS 1.2.

Nota:
Esri ha constatado que, al configurar el entorno de .NET para habilitar TLS 1.2, no habrá ningún problema con ArcGIS;  sin embargo, otras aplicaciones de .NET pueden verse afectadas si se cambia su comportamiento TLS predeterminado. Si es necesario, consulte a un profesional en sistemas informáticos cualificado.

Procedimiento

Nota:
Cuando haya configurado ArcGIS Desktop para utilizar TLS 1.2 y lo haya probado, vuelva a la página sobre TLS del Soporte técnico de Esri para obtener instrucciones sobre cómo utilizar TLS 1.2 con otros productos de Esri.

Los pasos para habilitar Windows para que utilice TLS 1.2 dependen de la versión de .NET Framework instalada en el sistema. Esri recomienda utilizar .NET4, a ser posible.

  1. Compruebe la versión de .NET que hay en uso. Puede obtener esta información del siguiente documento de la Ayuda de Microsoft:
    Cómo: Determinar qué versiones de .NET Framework están instaladas.
  2. Si .NET4 ya está instalado, siga estos pasos para configurar el sistema operativo Windows para que utilice TLS 1.2:
    1. Descargue el archivo zip: TLS_NET4.zip.
    2. Extraiga el contenido del archivo comprimido y haga doble clic en el archivo TLS_NET4.reg para crear las claves de registro de Windows adecuadas.
    3. Pruebe sus conexiones TLS 1.2 a ArcGIS Online.
  3. Si no tiene .NET4 instalado en el sistema, Esri recomienda que lo instale :
    1. Descargue e instale .NET4 desde el Centro de descargas de Microsoft:
      Microsoft .NET Framework 4.7 (instalador web).
    2. Siga los pasos de la Sección B de arriba.
  4. Si el sistema utiliza .NET versión 3.5.1, y no es factible actualizar a .NET4, siga estos pasos para habilitar TLS 1.2:
    1. Instale actualizaciones de Microsoft para habilitar TLS 1.2. Microsoft recomienda instalar todas las actualizaciones del sistema operativo. Consulte: Procedimientos recomendados sobre la seguridad de la capa de transporte (TLS) con .NET Framework: Requisitos para admitir TLS 1.2 con .NET Framework 3.5
      Las siguientes actualizaciones de TLS 1.2 están disponibles:
    2. Descargue el siguiente archivo ZIP: TLS_NET35.zip.
    3. Extraiga el archivo TLS_NET35.reg y haga doble clic en él para crear las claves de registro de Windows adecuadas.
    4. Pruebe sus conexiones TLS 1.2 a ArcGIS Online.
Nota:
Consulte las páginas Ciclo de vida del producto del sitio del Soporte técnico de Esri para ver el estado de soporte de cada versión publicada de ArcGIS Desktop.

Información relacionada