ERROR

error webgisdr {code:500 messages:["Error de la operación de exportación. No hay suficiente espacio en el disco"] status:"error"}

Last Published: April 25, 2020

Mensaje de error

Al ejecutar la utilidad webgisdr o la operación de exportar sitio del administrador de ArcGIS Server, se produce el siguiente error:

Error: 
{"code":500,"messages":["Error de la operación de exportación. No hay suficiente espacio en el disco"],"status":"error"}

Causa

Si los datos de ArcGIS Server que se exportan ocupan más espacio que el que hay disponible en el disco C:\, la exportación genera un error. Aunque puede parecer que hay suficiente espacio disponible, a menudo se desconoce que ArcGIS Server usa una ubicación temporal para realizar la exportación. Con la operación de exportación y un archivo de propiedades para crear una copia de seguridad de ArcGIS Enterprise, la copia de seguridad de cada componente se ubica en un directorio temporal en el equipo de cada componente antes de moverlo al directorio compartido que se especifica. Por lo tanto, los siguientes directorios deben tener la capacidad suficiente para dar cabida a la copia de seguridad de cada componente:

  • Portal for ArcGIS: \temp
  • ArcGIS Server: C:\Usuarios\\AppData\Local\Temp
  • ArcGIS Data Store: \temp

De forma predeterminada, la ubicación temporal de ArcGIS Server es: C:\Usuarios\\AppData\Local\Temp

Algunas organizaciones no tienen el espacio adecuado en el disco C: puesto que está reservado específicamente para el sistema operativo. Por lo tanto, si los datos de ArcGIS Server que se exportan ocupan más espacio que el que hay disponible en el disco, la exportación falla con el error mencionado anteriormente.

Solución o solución alternativa

Mueva la carpeta temporal a otro disco o ubicación con espacio suficiente. Asegúrese de que la cuenta de ArcGIS Server tenga acceso de lectura y escritura, como mínimo, en la nueva ubicación del disco.

Advertencia: 
Las siguientes instrucciones incluyen hacer cambios en la variable de entorno TEMP de la cuenta de Windows de ArcGIS Server. Si es necesario, consulte a un profesional en sistemas informáticos cualificado.

Esri no puede garantizar resultados por modificaciones incorrectas cuando sigue estas instrucciones. Por tanto, utilícelos asumiendo el riesgo correspondiente.

Para cambar la ubicación de la carpeta temporal del sistema, siga las instrucciones que figuran a continuación:

  1. Inicie sesión en un equipo del servidor como la cuenta de Windows que administra ArcGIS Server.
  2. Haga clic con el botón derecho en Equipo y, a continuación, haga clic en Propiedades.
  3. Haga clic en Configuración avanzada del sistema en el panel izquierdo.
  4. En el cuadro de diálogo Propiedades del sistema, haga clic en la pestaña Opciones avanzadas.
  5. En la parte inferior de ventana del cuadro de diálogo, haga clic en Variables de entorno.
User-added image
  1. En el cuadro de edición del valor de la variable, especifique la ruta al directorio para ArcGIS Server para compilar temporalmente sus copias de seguridad.
  2. Repita el proceso para las variables de entorno del usuario TMP y TEMP.
  3. Reinicie Windows para que la configuración surta efecto.
User-added image

Id. de artículo:000018777

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema