PROBLEMA

Collector for ArcGIS (Windows) no puede capturar una entidad de puntos con un receptor GNSS

Last Published: April 25, 2020

Descripción

Al intentar capturar una entidad de puntos con un receptor GNSS (siglas en inglés de Sistema global de navegación por satélite) con Collector for ArcGIS (Windows), se devuelven de forma intermitente errores que indican "Ubicación no disponible" o "Posición no disponible". Pruebas adicionales realizadas utilizando la misma entidad de puntos con otras aplicaciones y funciones de ArcGIS, por ejemplo, el cálculo de promedios de puntos o la creación de líneas y polígonos indican que funcionan de la forma esperada.

Causa

Este problema es exclusivo de las entidades de puntos sencillas en Collector for ArcGIS (Windows), y se debe a la falta de sincronización del reloj del sistema operativo (SO) Windows con Collector for ArcGIS (Windows). El mensaje de error aparece si, al comparar la hora que marca el receptor GNSS con la hora que marca el SO, se detecta alguna diferencia, hasta de segundos.

La hora del SO puede ser imprecisa especialmente si se trabaja sin conexión durante periodos prolongados, o si la opción de sincronización automática del reloj está deshabilitada.

Nota:
Collector for ArcGIS (Android e iOS) compara la hora de la ubicación anterior en lugar de la hora del SO, de modo que no se ve afectada si la hora del SO no está sincronizada con la aplicación.

Solución o solución alternativa

Para resolver el problema, habilite la opción para sincronizar y actualizar la hora del SO Windows. Si trabaja sin conexión y la sincronización no está deshabilitada, se recomienda que restablezca la conectividad para permitir que Windows actualice la hora automáticamente.

Puede aplicar los siguientes métodos si la sincronización está deshabilitada:

Habilitar y actualizar la sincronización de la hora
Puede utilizar esta alternativa si la opción de sincronización de la hora de Windows está deshabilitada. Para volver a habilitar la sincronización y actualizar la hora:

  1. Haga clic en el reloj de Windows y elija Cambiar la configuración de fecha y hora....
  2. Haga clic en la pestaña Hora de Internet.
  3. Si la sincronización está deshabilitada, debería aparecer este mensaje: "Este equipo no está configurado para sincronizarse automáticamente con un servidor horario de Internet".
  4. Haga clic en Cambiar la configuración... y active la opción Sincronizar con un servidor horario de Internet.
  5. En el menú desplegable Servidor, seleccione time.windows.com y haga clic en Actualizar ahora.
  6. Haga clic en Aceptar.

Usar el comando Ejecutar de Windows

  1. En Windows, haga clic en Inicio, escriba services.msc y pulse Intro.
  2. Busque el servicio llamado Hora de Windows.
  3. Haga clic con el botón derecho en Hora de Windows y elija Propiedades para comprobar el estado del servicio.
  4. Si Estado del servicio es Detenido, haga clic en Iniciar para iniciar el servicio y haga clic en Aceptar.
  5. Haga clic con el botón derecho en el servicio Hora de Windows y haga clic en Reiniciar.
  6. Reinicie el equipo.

Usar el símbolo del sistema de Windows

  1. Haga clic en el botón Inicio de Windows y vaya a Todos los programas > Accesorios. Escriba cmd y pulse Intro.
  2. Haga clic con el botón derecho en Símbolo del sistema y elija Ejecutar como administrador.
  3. Escriba los siguientes comandos de forma individual y pulse Intro.
    net stop w32time
    w32tm /unregister
    w32tm /register
    net start w32time
    w32tm /resync
  4. Reinicie el equipo.
Nota:
W32tm.exe se utiliza para configurar los ajustes del servicio Hora de Windows. También lo puede utilizar para diagnosticar problemas con el servicio de hora.

Id. de artículo:000018485

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema