Español

Cómo: Importar datos XY a ArcMap y convertir los datos en un shapefile o una clase de entidad en ArcMap 10.1 y versiones posteriores

Resumen

ArcMap (y ArcGIS Pro) no pueden leer datos en grados-minutos-segundos (DMS), por lo que estos datos deben convertirse en grados decimales (DD) antes de importarlos.

Los pasos siguientes proporcionan instrucciones para asignar formato a las coordenadas XY, usar Microsoft Excel y convertir estos datos en un shapefile o clase de entidad de geodatabase en ArcMap.

ArcMap puede leer distintos formatos de tabla, incluyendo DBase III; DBase IV; .prn, .txt, .csv, .xls y xlsx.

Después de 2003, Excel ya no genera archivos en formato DBase.

Procedimiento

  1. Para asegurarse de que ArcMap lee correctamente los datos del archivo, use Excel para asignar formato a las columnas que contienen los valores de longitud (X o este) y latitud (Y o norte) como NUMBER, con un mínimo de 8 posiciones decimales para datos de grados decimales. Con coordenadas en metros o pies, 2 o 3 decimales son suficientes.
El gráfico siguiente muestra la distribución de valores positivos y negativos para las coordenadas de longitud (X) y latitud (Y) en todo el mundo.

[O-Image] Decimal degree coordinates and signs
Nota:
Asigne al campo Id. el formato de Número, sin decimales.
Asigne a Longitud y Latitud el formato de Número, con al menos 8 y hasta 11 decimales.
Asigne a Elevación el formato de Número, con hasta 2 decimales.
Asigne a Descripción el formato de texto, con una longitud de hasta 255 caracteres.
  1. Las descripciones del contenido de cada columna también son necesarias en el archivo de salida. Etiquete las columnas Id., Longitud, Latitud, Elevación (si se incluye), Descripción, etc.
  2. Después de asignar formato a los campos de la tabla, seleccione todas las celdas de las filas y columnas rellenadas y vaya a Archivo > Área de impresión > Establecer área de impresión o Diseño de página > Área de impresión > Establecer área de impresión. La ubicación exacta depende de la versión de Excel utilizada.
  3. Vaya a Archivo > Guardar como y seleccione un formato compatible en las opciones disponibles en Excel. Haga clic en si Excel advierte de que algún formato no es compatible con este formato de archivo.
  4. Salga de Excel. Haga clic en No cuando Excel le pregunte si desea guardar los cambios.

Los siguientes pasos se realizan en ArcMap.

  1. Para agregar los datos del archivo formateado a ArcMap, seleccione el botón Agregar datos y vaya a la carpeta del equipo en la que se ha guardado la tabla que contiene las coordenadas, seleccione el archivo y haga clic en Agregar.
  2. En la Tabla de contenido, haga clic con el botón derecho en el nombre de la tabla y seleccione Mostrar datos XY.
    Advertencia:
    ArcMap aplica el sistema de coordenadas del marco de datos a los datos XY. Es probable que este sistema de coordenadas sea incorrecto para los datos.
    Consulte el siguiente artículo de la Base de conocimiento: Cómo: Identificar la referencia espacial, la proyección o el sistema de coordenadas de los datos
    para obtener ayuda para identificar el tipo de sistema de coordenadas y el sistema de coordenadas específico para sus valores de coordenadas.
  3. Haga clic en el botón Editar para abrir el cuadro de diálogo Propiedades de referencia espacial. Haga clic en el botón Seleccionar para seleccionar un sistema de coordenadas para los datos.
    Nota:
    Si se muestra un mensaje de advertencia que indica que falta el campo Object-ID, es seguro pasarlo por alto y hacer clic en Aceptar. 
    [O-Image]
    
    Como ejemplo, los datos GPS se capturan la mayoría de las veces en unidades de grados decimales o de lat/long, que es un sistema de coordenadas geográficas. Abra este directorio. En la mayoría de los casos, los datos GPS se capturan en el datum WGS 1984, así que abra la carpeta World y seleccione WGS_1984.prj.

    La mejor práctica es obtener la información del sistema de coordenadas de los datos de la fuente de datos.
  4. Después de definir la proyección, haga clic en Agregar, Aplicar y Aceptar en el cuadro de diálogo Propiedades de la referencia espacial. Haga clic en Aceptar en el cuadro de diálogo Agregar datos XY. Los puntos se dibujan como un tema de evento en ArcMap. Compruebe que el tema de evento se corresponde con los otros datos de ArcMap.
  5. Los datos también se pueden volver a proyectar en el sistema de coordenadas del marco de datos de ArcMap durante este proceso. Vaya a Ver > Propiedades del marco de datos. Haga clic en la pestaña Sistema de coordenadas y seleccione la proyección de salida deseada para los nuevos datos. Para proyectar mientras se exporta, haga clic con el botón derecho en el tema Eventos, seleccione Datos > Exportar datos y cambie el botón de radio para exportar al sistema de coordenadas del marco de datos. Los datos de salida se crean en el sistema de coordenadas de salida seleccionado.
Nota:
Si ArcMap advierte de un "sistema de coordenadas geográficas diferente del de otros datos del mapa", vaya a
la pestaña Ver > Propiedades del marco de datos > Sistema de coordenadas.  Haga clic en el botón Transformaciones y seleccione la transformación de datum
correcta para transformar entre los datums del marco de datos de ArcMap para el área en la que se encuentran los datos.
Para obtener una lista de las transformaciones geográficas (datum), sus áreas de uso y precisión, consulte el artículo siguiente:
Cómo: Seleccionar la transformación geográfica (datum) correcta al proyectar entre datums.
En la sección Información relacionada del artículo, descargue la lista de transformaciones para
la versión de ArcGIS Desktop instalada en el equipo.
Nota:
Si las coordenadas de entrada están en grados-minutos-segundos (DMS), se puede utilizar la herramienta Convertir notación de coordenadas, situada en
ArcToolbox > Herramientas de administración de datos > Proyecciones y transformaciones, para convertir dichos
valores a grados decimales (DD).  Consulte la ayuda de la herramienta para obtener instrucciones para asignar formato a los datos de entrada.

Información relacionada