Español

Problema: No se puede conectar a una geodatabase corporativa de solo lectura

Descripción

Al conectarse a una geodatabase corporativa de solo lectura desde un cliente de ArcGIS, o al registrar una geodatabase corporativa de solo lectura con ArcGIS Server, aparece un error que indica que no se puede encontrar la tabla de DBMS.

Causa

Después de crear y actualizar una geodatabase corporativa, o tras la aplicación de un parche, se pueden escribir filas adicionales en las tablas del sistema de geodatabase. Esto solo ocurre en la primera conexión después de la creación o actualización. Como las modificaciones de las tablas no son compatibles con las bases de datos de solo lectura, el proceso falla y el error se devuelve al cliente que se conecta.

Solución o solución alternativa

Si la geodatabase de solo lectura es la base de datos secundaria en una solución de alta disponibilidad, como SQL Server AlwaysOn o PostgreSQL Hot Standby, conéctese siempre primero a la base de datos principal o maestra legible después de actualizar o crear una nueva geodatabase. Con esto se completan las actualizaciones requeridas en la geodatabase principal o maestra que se replica en las geodatabases de solo lectura. Si la geodatabase se configura como de solo lectura a través de algún otro mecanismo, debe usarse solo después de realizar la conexión inicial y mientras la base de datos es editable.

Última modificación: 9/11/2020

Id. de artículo: 000018011

Software: ArcGIS Pro 2.6, 2.5.2, 2.5.1, 2.5, 2.4.3, 2.4.2, 2.4.1, 2.4, 2.3.3, 2.3.2, 2.3.1, 2.3, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2, 2.1.3, 2.1.2, 2.1.1, 2.1, 2.0.1, 2.0, 1.4.1, 1.4, 1.3.1, 1.3, 1.2 Servidor de geoanálisis de ArcGIS 10.8.1, 10.8, 10.7.1, 10.7, 10.6.1, 10.6, 10.5.1, 10.5 ArcMap 10.8.1, 10.8, 10.7.1, 10.7, 10.6.1, 10.6, 10.5.1, 10.5, 10.4.1, 10.4, 10.3.1, 10.3, 10.2.2, 10.2.1, 10.2, 10.1, 10