PROBLEMA

No se puede conectar a una geodatabase corporativa de solo lectura

Last Published: September 11, 2020

Descripción

Al conectarse a una geodatabase corporativa de solo lectura desde un cliente de ArcGIS, o al registrar una geodatabase corporativa de solo lectura con ArcGIS Server, aparece un error que indica que no se puede encontrar la tabla de DBMS.

Causa

Después de crear y actualizar una geodatabase corporativa, o tras la aplicación de un parche, se pueden escribir filas adicionales en las tablas del sistema de geodatabase. Esto solo ocurre en la primera conexión después de la creación o actualización. Como las modificaciones de las tablas no son compatibles con las bases de datos de solo lectura, el proceso falla y el error se devuelve al cliente que se conecta.

Solución o solución alternativa

Si la geodatabase de solo lectura es la base de datos secundaria en una solución de alta disponibilidad, como SQL Server AlwaysOn o PostgreSQL Hot Standby, conéctese siempre primero a la base de datos principal o maestra legible después de actualizar o crear una nueva geodatabase. Con esto se completan las actualizaciones requeridas en la geodatabase principal o maestra que se replica en las geodatabases de solo lectura. Si la geodatabase se configura como de solo lectura a través de algún otro mecanismo, debe usarse solo después de realizar la conexión inicial y mientras la base de datos es editable.

Id. de artículo:000018011

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Descubrir más sobre este tema