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Error: Las instancias del servicio de geoprocesamiento se bloquean después de instalar parches de Windows en Microsoft Windows Server 2008 R2 o Windows 7

Descripción

Después de instalar los siguientes parches de Windows en Server 2008 R2 o Windows 7, las instancias del servicio de geoprocesamiento se bloquean en ArcGIS Server (independientemente de la versión publicada):

  • Paquete acumulativo mensual de calidad de seguridad de enero de 2018 para Windows Server 2008 R2 para sistemas basados en x64 (KB4056894)
  • Actualización de seguridad acumulativa para Internet Explorer (KB4056568)
  • 3 de enero de 2018, actualización solo de seguridad (KB4056897)
  • 13 de febrero de 2018: KB4074598 (paquete acumulativo mensual)
Nota:
Los parches de los paquetes de seguridad mensuales de Microsoft son acumulativos. Es posible que los futuros parches incluyan el contenido de los parches mencionados anteriormente. Póngase en contacto con el departamento de Soporte técnico de Esri si se le presentan problemas descritos en este artículo pero los parches mencionados anteriormente no están instalados.

Se genera un error (código #8273) en los registros de ArcGIS Server durante la creación de procesos SOC:

El servicio no se pudo iniciar
Utilities.Printingtools.GPServer:
MACHINENAME.DOMAIN.COM
El servicio que contiene el proceso se ha averiado para "SERVICENAME.GPServer". Compruebe que se haya generado un informe de error en "C:\arcgisserver\logs\MACHINENAME.DOMAIN.COM\errorreports". Para enviar un informe de errores a Esri, escriba un correo electrónico a Arcgiserrorreport@esri.com y adjunte el archivo de informe de errores.
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Nota:
Tenga en cuenta que, aunque se devuelve un error, no se genera el archivo de informe de errores.

Causa

El problema del servicio de geoprocesamiento es una consecuencia indirecta relacionada con los parches para Windows Server 2008 R2 y Windows 7 mencionados anteriormente, que se publicaron para solucionar las vulnerabilidades de seguridad del procesador conocidas como Meltdown y Spectre. Sin embargo, las vulnerabilidades Meltdown y Spectre no causan directamente este problema. Esri ha investigado el problema con Microsoft y está publicando parches para solucionarlo.

Un blog que describe las Vulnerabilidades Meltdown y Spectre del procesador incluye las recomendaciones de Esri para las implementaciones de ArcGIS y proporciona una serie de referencias para vulnerabilidades y avisos específicos del proveedor. También se publicó un blog sobre los parches de software de Esri publicados para el problema que contiene información adicional. Ambos blogs se actualizarán con nueva información a medida que se publique.

Solución

Los parches para este problema están disponibles en el vínculo que figura a continuación, ya que se publican para las versiones de ArcGIS (for) Server 10.6, 10.5.1, 10.5, 10.4.1, 10.4, 10.3.1, 10.3, 10.2.2 o 10.2.1:

Si ejecuta ArcGIS for Server 10.2.1 o posterior en Windows Server 2008 R2 o Windows 7, compruebe la página del Parche de inicio del servicio de geoprocesamiento de ArcGIS Server para determinar si se ha publicado el parche correspondiente a la versión de ArcGIS Server instalada. Si es así, descargue e instale el parche y siga las instrucciones de la página. Se recomienda encarecidamente comprobar que todos los servicios de geoprocesamiento funcionan correctamente una vez instalado el parche. Si algún servicio de geoprocesamiento aún no funciona, detenga e inicie el servicio manualmente desde ArcGIS Server Manager.

Si su organización se ve afectada por este defecto o si otro parche de proveedor interfiere con la implementación de ArcGIS, póngase en contacto con el Soporte técnico de Esri.

Si hubiera preguntas o inquietudes sobre el manejo de estas vulnerabilidades en una implementación de ArcGIS, póngase en contacto con el Equipo de estándares y arquitectura de seguridad de Esri para informar de un problema de seguridad.

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