ERROR

Es posible que la actualización de algunos dispositivos a la versión 7.x del sistema operativo Android no permita abrir los mapas web existentes sin un restablecimiento de fábrica y la reinstalación de Collector for ArcGIS

Last Published: April 25, 2020

Descripción

Al actualizar ciertos dispositivos Android a la versión 7.x, los mapas web existentes ya no se inician correctamente en la aplicación Collector for ArcGIS. Además, al intentar iniciar un mapa web, incluidos los mapas 'Pruébelo' disponibles de forma gratuita, el mapa se inicia, pero la carga no se completa. Las capas y los mapas base no se renderizan.

Causa

Este es un problema conocido. Es posible que la actualización de algunos dispositivos Samsung con Android no permita a los usuarios abrir mapas web existentes a menos que se realice un restablecimiento de fábrica en el dispositivo y Collector for ArcGIS se reinstale. El problema no se debe a la incompatibilidad con Android 7.x, ya que la versión del sistema operativo Android es totalmente compatible con la aplicación Collector for ArcGIS.

La siguiente es una lista de dispositivos Android de los que se ha informado que exhiben este comportamiento después de actualizar a Android 7.x:

  • Samsung Galaxy Tab A
  • Samsung Galaxy Tab S2
  • Samsung Galaxy Note 4
Nota:
Otros tipos de dispositivos Android también pueden experimentar este comportamiento.

Solución alternativa

Advertencia: 
Antes de continuar con la siguiente alternativa, asegúrese de hacer una copia de seguridad de los datos o la información valiosa del dispositivo, ya que dicha información se elimina del dispositivo cuando se realiza un restablecimiento de fábrica.
  1. Asegúrese de que todas las ediciones sin conexión se hayan sincronizado correctamente desde Collector for ArcGIS.
  2. Realice copias de seguridad de los mapas sin conexión existentes.
    1. Conecte el dispositivo Android a un PC mediante un cable USB.
    2. En el Explorador de Windows, vaya al dispositivo y localice la carpeta ArcGIS_Collector.
    3. Copie y pegue toda la carpeta en el escritorio del PC. Esta es la carpeta de copia de seguridad.
  3. Realice un restablecimiento de fábrica completo, siguiendo los pasos descritos en la documentación del dispositivo que se está utilizando.
  4. Una vez completado el restablecimiento de fábrica, vuelva a instalar Collector for ArcGIS.
  5. Restaure los mapas sin conexión existentes:
    1. Conecte el dispositivo Android a un PC mediante un cable USB.
    2. En el Explorador de Windows, vaya al dispositivo.
    3. Copie y pegue la carpeta ArcGIS_Collector del Paso 2 de nuevo en el almacenamiento interno del dispositivo.
  6. Inicie Collector for ArcGIS.

Id. de artículo:000017074

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga