ERROR

Infracción de la restricción PRIMARY KEY [valor]. No se puede insertar una clave duplicada en el objeto [valor]. El valor clave duplicado es [valor].

Last Published: March 30, 2021

Mensaje de error

Al administrar datos versionados con operaciones como comprimir o conciliar/publicar, es posible que se devuelva el siguiente mensaje de error:

Error: Infracción de la restricción PRIMARY KEY [valor]. No se puede insertar una clave duplicada en el objeto [valor]. El valor clave duplicado es [valor].

Causa

Incoherencias descubiertas entre las tablas de adiciones y borrados, como filas separadas o duplicadas de las tablas delta o de la tabla de negocios versionada. Estas incoherencias pueden deberse a varios métodos de edición, por ejemplo, la omisión de una versión intermedia durante la conciliación/publicación.

Nota: Al conciliar versiones, se recomienda utilizar la pestaña Orden de conciliación en el cuadro de diálogo Administración de la geodatabase. Para obtener más información, consulte ArcMap: Orden de conciliación recomendado.

Solución o solución alternativa

Para resolver este problema, identifique y repare las incoherencias dentro de las tablas versionadas, como se describe a continuación:

Nota: Solo un administrador de la geodatabase tiene los privilegios necesarios para ejecutar el diagnóstico y las herramientas de reparación. Asegúrese de realizar una copia de seguridad de la base de datos y de que nadie esté editando en la geodatabase antes de ejecutar la reparación.
  1. Ejecute la herramienta Diagnosticar tablas de versión. Esta herramienta produce registros que identifican las tablas de versiones de clase de entidad con incoherencias.
    1. En Catálogo, vaya a Cajas de herramientas del sistema > Herramientas de administración de datos > Administración de geodatabase > Diagnosticar tablas de versión
    2. En la ventana Diagnosticar tablas de versión, asigne la conexión de base de datos de entrada deseada y la ubicación del registro de las tablas de versiones de diagnóstico y haga clic en Aceptar.
  2. Ejecute la herramienta Reparar tablas de versión para abordar cualquier incoherencia del paso 1.
    1. En Catálogo, vaya a Cajas de herramientas del sistema > Herramientas de administración de datos > Administración de geodatabase > Reparar tablas de versión.
    2. En la ventana Reparar tablas de versión, asigne la conexión de base de datos de entrada deseada y el registro de las tablas de versiones de reparación y haga clic en Aceptar.
Nota: Consulte los documentos de ayuda para conocer parámetros adicionales de las herramientas. Los vínculos se enumeran a continuación. 

Id. de artículo:000016425

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema