ERROR

Imposible iniciar sesión en Portaladmin API tras actualizarlo a Portal for ArcGIS 10.5.1

Last Published: April 25, 2020

Mensaje de error

Si Portal for ArcGIS se actualiza a la versión 10.5.1 y la versión instalada anteriormente tiene configurado un servidor proxy de reenvío, el usuario puede iniciar sesión en la aplicación de inicio de Portal for ArcGIS y Sharing API, pero no en Portaladmin API.

Causa

El Portaladmin API es incapaz de autenticar mediante el servidor proxy de reenvío especificado. Al intentar iniciar sesión, ocurre uno de los siguientes errores en el navegador web:

Error: 
"Token no válido"
o bien,
"No tiene autorización para acceder a este recurso"

Además, los registros del Portal muestran mensajes parecidos a:

Error:
Error al generar un token para el usuario "portaladmin". java.lang.Exception: El servidor devolvió el código de estado HTTP 404. URL requerida: https://portaladmin.domain.com:7443/arcgis/sharing/generateToken

Solución o solución alternativa

Si es posible, antes de actualizar a Portal for ArcGIS 10.5.1, agregue el parámetro de proxy de reenvío de JavaScript Object Notation (JSON), "nonProxyHosts", a las propiedades de sistema de Portal for ArcGIS.

  1. Inicie sesión en Portaladmin API con una cuenta de administrador.
    • Ejemplo: https://portal.domain.com:7443/arcgis/portaladmin
  2. Seleccione Sistema > Propiedades > Actualizar (https://portal.domain.com:7443/arcgis/portaladmin/system/properties/update).
  3. Agregue "nonProxyHosts":"portal.domain.com" a la configuración de proxy de reenvío (sustituya portal.domain.com por el nombre de dominio totalmente calificado (FQDN) del equipo en el que está instalado Portal for ArcGIS).
    • Ejemplo:
"httpProxyHost":"forwardproxy.domain.com","httpsProxyHost":"forwardproxy.domain.com","httpProxyPort":80,"httpsProxyPort":443","nonProxyHosts":"portal.domain.com"
  1. Seleccione Actualizar propiedades para guardar los cambios.
  2. Cierre sesión en Portal for ArcGIS. La aplicación se reinicia.
  3. Cuando Portal for ArcGIS haya terminado el reinicio, vuelva a iniciar sesión en Portaladmin para verificar que se guardó la configuración.
  4. Cree una copia de seguridad con la utilidad de copia de seguridad de ArcGIS Enterprise.
  5. Cuando la copia de seguridad haya terminado, actualice a Portal for ArcGIS 10.5.1.
Si ya se ha realizado la actualización. Existen dos opciones para resolver este error:
  • Contacte con el Soporte técnico de Esri y reciba asistencia para restablecer Portal for ArcGIS a la versión anterior, o
  • Modifique las páginas catalina.properties y portal-config.properties como se explica a continuación:
  1. Detenga el servicio de Windows de Portal for ArcGIS en la consola Servicios (services.msc):
    • En el cuadro de diálogo Ejecutar, escriba services.msc y pulse Intro.
  2. Cree una copia de seguridad del archivo catalina.properties, por ejemplo:
  3. Abra el archivo catalina.properties con un editor de texto.
  4. Comente las siguientes entradas:
    • http.proxyHost =
    • https.proxyHost =
    • http.proxyPort =
    • https.proxyPort =
    • nonProxyHosts =
  5. Guarde el archivo catalina.properties
  6. Cree una copia de seguridad del archivo portal-config.properties, por ejemplo:
  7. Abra el archivo portal-config.properties con un editor de texto.
  8. Comente las siguientes entradas:
    • http.proxyHost =
    • https.proxyHost =
    • http.proxyPort =
    • https.proxyPort =
    • nonProxyHosts =
  9. Guarde el archivo portal-config.properties.
  10. Inicie los servicios de Windows de Portal for ArcGIS en la consola Servicios (services.msc).
  11. Inicie sesión en Portaladmin API de Portal for ArcGIS (https://portal.domain.com:7443/arcgis/portaladmin)
  12. Seleccione Sistema > Propiedades > Actualizar.
  13. Agregue "nonProxyHosts":"portal.domain.com". Sustituya portal.domain.com por el nombre del host en el que está instalado Portal for ArcGIS. Por ejemplo:
  • "httpProxyHost":"forwardproxy.domain.com","httpsProxyHost":"forwardproxy.domain.com","httpProxyPort":80,"httpsProxyPort":443","nonProxyHosts":"portal.domain.com"
  1. Seleccione Actualizar propiedades.
  2. Cree una copia de seguridad con la utilidad de copia de seguridad de ArcGIS Enterprise.

Id. de artículo:000016419

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema