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Problema: La función Mi ubicación no funciona

Descripción

Muchas aplicaciones y mapas web tienen botones de ubicación, como Mi ubicación, Localizarme, etc., concebidos para solicitar al mapa o aplicación que aplique su ubicación a un zoom o widget de una aplicación. En algunos navegadores, estos botones pueden producir resultados inesperados. Puede que no ocurra nada o puede que al pulsar el botón aparezca un mensaje de error.

Causa

El control sobre el uso de su ubicación es una función controlada por el navegador, más que por el mapa web o la aplicación. Los desarrolladores de navegadores implementan precauciones de seguridad cada vez más estrictas para proteger la privacidad.

  • Chrome: las versiones 50 y superiores requieren que cualquier solicitud de ubicación se realice a través de un vínculo HTTPS o una conexión segura para continuar.
  • Safari: las versiones 10.0 y superiores requerirán la función de geolocalización solo a través de HTTPS.
  • Internet Explorer: la versión 11 aún permite la geolocalización a través de HTTP.
  • Edge: Edge no trabaja con la geolocalización excepto a través de HTTPS.
  • Mozilla Firefox: la versión 50.1.0 aún permite la geolocalización a través de HTTP.

Solución o solución alternativa

Compruebe la URL de la página a la que se accede en el navegador. Si empieza por HTTP, cambie la URL a HTTPS.
Tenga en cuenta que también pueden producirse problemas de contenido mixto. Es posible acceder a una aplicación a través de HTTPS, pero si, por ejemplo, un logotipo está alojado en o se agregó como URL HTTP, es necesario volver a alojar el logotipo con una URL HTTPS o, de lo contrario, el navegador puede captar la imagen no segura y suponer que el sitio no es seguro y bloquear los servicios de geolocalización. A menudo, se pueden usar las herramientas para desarrolladores de los navegadores o una herramienta de depuración como Fiddler para diagnosticar estos problemas.

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