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Problema: Se produce el error 000594 o 000595 al exportar un shapefile a una geodatabase personal

Descripción

Al exportar un shapefile a una geodatabase personal, puede aparecer un error que devuelve los siguientes errores genéricos, "Error 000594" o "Error 000595".

Causa

Existen varios motivos para estos problemas, pero típicamente se debe a:

  • El tamaño del shapefile es excesivo para una geodatabase personal.
  • El shapefile contiene geometría dañada.
  • El shapefile se ha corrompido de forma irrecuperable.

Solución o solución alternativa

En función del motivo, utilice las siguientes alternativas para resolver el problema.

  • Asegúrese de que el tamaño del shapefile no rebase los 2 GB antes de exportarlo a una geodatabase personal. Si no es posible reducir el tamaño del shapefile, utilice otro tipo de geodatabase que tenga una mayor capacidad, por ejemplo, una geodatabase de archivos o una geodatabase corporativa. Las geodatabases personales utilizan la estructura de archivos de datos de Microsoft Access (.mdb), que admite geodatabases limitadas a un tamaño de 2 GB o menos.
    Nota:
    El tamaño efectivo de la base de datos está entre 250 y 500 MB antes de que el rendimiento de la base de datos comience a bajar.
    Para ver una comparación de los distintos tipos de geodatabases y sus tamaños, consulte Tipos de geodatabases.
  • Asegúrese de que el shapefile no presente ninguna geometría dañada antes de exportarlo a la geodatabase personal. Consulte Verificar y reparar geometrías para obtener más información.
  • Si el shapefile está dañado y no se puede recuperar con los métodos recomendados en Cómo: Recuperar un shapefile dañado, cree una nueva clase de entidad en la geodatabase personal y cargue los datos del shapefile en la clase de entidad vacía mediante la herramienta Cargar datos.

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