Español
Continue in the app
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

Preguntas frecuentes: ¿Se pueden utilizar las herramientas de línea de comandos de ArcSDE con geodatabases versión 10.3, 10.3.1, 10.4, 10.4.1 y 10.5?

Pregunta

Preguntas frecuentes: ¿Se pueden utilizar las herramientas de línea de comandos de ArcSDE con geodatabases versión 10.3, 10.3.1, 10.4, 10.4.1 y 10.5?

Respuesta

Los comandos de administración de ArcSDE ya no están disponibles a partir de la versión 10.3 de ArcGIS for Server.

Se recomienda migrar los flujos de trabajo que utilicen herramientas de línea de comandos ArcSDE a soluciones proporcionadas dentro de la interfaz de usuario de ArcGIS Desktop y las funciones de ArcPy disponibles.

Nota: Se siguen desarrollando funcionalidades para los flujos de trabajo adicionales que anteriormente se completaban utilizando herramientas de línea de comandos.
A continuación, se muestra una serie de sugerencias que se deben tener en cuenta:
  • Las herramientas de línea de comandos admiten utilizar e interactuar con versiones de geodatabase hasta la versión 10.2.2.
  • Los clientes de ArcGIS pueden actualizar a la versión 10.3/10.3.1/10.4/10.4.1/10.5 y, aun así, conectarse a una geodatabase de la versión 10.2.2. Consulte la página de compatibilidad de cliente y geodatabase.
  • Después de actualizar la geodatabase a versiones posteriores a 10.2.2, se recomienda utilizar funciones de ArcPy o herramientas dentro de la interfaz de usuario para interactuar con la geodatabase.
  • Para revisar flujos de trabajo que no están disponibles en este momento en la interfaz de usuario con el fin de hallar una solución alternativa, o bien para registrar una mejora, póngase en contacto con el Soporte técnico de Esri.
  • Ya no se publican herramientas de línea de comandos para su descarga para las versiones 10.3 y posteriores, de modo que no se realizarán correcciones de comportamientos inesperados en el uso de estas herramientas.
Nota: Si en este momento no existen sustitutos para los flujos de trabajo de línea de comandos en ArcGIS for Desktop, las herramientas de línea de comandos 10.2.2 continuarán teniendo compatibilidad con versiones posteriores con las geodatabases de las versiones 10.3/10.3.1/10.4/10.4.1/10.5, con las limitaciones siguientes:
  • Las herramientas de línea de comandos de ArcSDE solo serán compatibles cuando se usen de la forma prevista, como una aplicación cliente independiente de sus geodatabases de ArcGIS (que pueden ser geodatabases de la versión 10.2.2, 10.3, 10.3.1, 10.4, 10.4.1 o 10.5.x).
  • Las bibliotecas no se deben combinar con otras aplicaciones de ArcGIS.
  • Los comandos, por ejemplo, sdeexport/sdeimport, solo serán compatibles con colecciones existentes de tipos de datos disponibles con las versiones 10.2.2, 10.3, 10.3.1, 10.4, 10.4.1 y 10.5. Si están disponibles nuevos tipos de datos de Esri en versiones futuras (por ejemplo, números enteros de 64 bits), estos no serán compatibles.
  • Los comandos solo se admitirán a través de una conexión directa.

Related Information

Última modificación: 11/25/2020

Id. de artículo: 000013590

Software: ArcGIS GeoAnalytics Server 10.8.1, 10.8, 10.7.1, 10.7, 10.6.1, 10.6, 10.5.1, 10.5