Español

Error: No se encontraron componentes GUI en este add-in. La versión del add-in no coincide

Mensaje de error

Al intentar instalar un add-in en ArcMap con el Administrador de add-ins, aparece el siguiente mensaje de error:

No se encontraron componentes GUI en este add-in. La versión del add-in no coincide.
[O-Image]

Causa

Este error se produce si la versión indicada en el archivo Config.esriaddinx es superior a la versión de ArcGIS que instala el add-in.

Nota:
Los add-ins no permiten la compatibilidad con versiones anteriores, es decir, si un add-in está dirigido a la versión 10.2.x de ArcGIS, el add-in funciona en la versión 10.2.x o posteriores, pero no en la versión 10.1.x o inferiores.

Solución o solución alternativa

La solución proporcionada indica a los usuarios cómo actualizar la versión del add-in en Visual Studio mediante el código fuente del proyecto del add-in.

  1. En Visual Studio, descargue el proyecto haciendo clic con el botón derecho en el nombre de la carpeta del proyecto en el Explorador de soluciones y seleccionando la opción "Descargar el proyecto".
  2. Cuando visualice el archivo .csproj, haga clic con el botón derecho en el nombre del archivo y seleccione la opción "Editar".
  3. Si se utiliza ArcGIS 10.2.x o posterior, cambie todas las etiquetas XML que contienen la siguiente ruta:
    de:
    C:\Archivos de programa (x86)\MSBuild\Esri\ESRI.ArcGIS.AddIns.targets
    a:
    C:\Archivos de programa (x86)\MSBuild\Esri\ESRI.ArcGIS.AddIns.11.targets
  4. Actualice la versión de destino. Si se utiliza, por ejemplo, ArcGIS 10.2.x, cambie la versión de destino a la 10.2.
    10.2
  5. Guarde el archivo .csproj y ciérrelo.
  6. Vuelva a cargar el proyecto haciendo clic con el botón derecho en la carpeta del proyecto y seleccionando la opción "Volver a cargar el proyecto".
  7. Abra el archivo Config.esriaddinx y actualice la versión de destino.
    
      version="10.2" />
    
  8. Compile el add-in y utilice el archivo esriAddIn recién creado para instalar el add-in. El add-in debería instalarse ahora sin mostrar el error.

Información relacionada