Español

Cómo: Importar tablas de datos XY a ArcMap y convertir los datos en un shapefile con ArcMap 10.0 y versiones anteriores

Resumen

Nota: 
La información de este artículo solo se aplica a las versiones 10.0 y anteriores de ArcGIS. Es posible que versiones posteriores de ArcGIS incluyan funcionalidades distintas, así como nombres y ubicaciones distintos para menús, comandos y herramientas de geoprocesamiento. Para llevar a cabo estas acciones en ArcGIS 10.1 y versiones posteriores, consulte Cómo: Importar datos XY a ArcMap y convertir los datos en un shapefile o una clase de entidad en ArcMap 10.1 y versiones posteriores

ArcMap (y ArcGIS Pro) no pueden leer datos en grados-minutos-segundos (DMS), por lo que estos datos deben convertirse en grados decimales (DD) antes de importarlos.

Los pasos siguientes proporcionan instrucciones para formatear los datos XY en grados decimales, usar Microsoft Excel y convertir esos datos en un shapefile o una clase de entidad de geodatabase en ArcMap.

Hay varios formatos de tabla que ArcMap puede leer para incorporar los datos de puntos a ArcMap como tema de evento.

Nota:
En la versión 9.1 y anteriores, ArcMap puede leer los siguientes formatos: DBase III, DBase IV, .prn, .txt y .csv. Si existen, las hojas adicionales se deben eliminar de estos formatos en Excel.
Nota:
En la versión 9.2 y en versiones posteriores, ArcMap puede leer los formatos anteriores junto con las hojas de cálculo .xls y .xlsx. En versiones más recientes de Excel, ya no se admiten los formatos de archivo DBase III y DBase IV (.dbf).

Procedimiento

  1. Para asegurarse de que ArcMap lee correctamente los datos del archivo, use Excel para formatear las columnas que contienen los valores de longitud (X o este) y latitud (Y o norte) como NUMBER, con un mínimo de 8 posiciones decimales.

    Se requieren descripciones del contenido de cada columna en el archivo de salida. Etiquete las columnas como Id., Longitud, Latitud, Descripción, etc.
El gráfico siguiente muestra la distribución de valores positivos y negativos para las coordenadas de longitud (X) y latitud (Y) en todo el mundo.

[O-Image] Decimal degree coordinates and signs
  1. Después de dar formato al archivo, seleccione todas las celdas de las filas y las columnas con valores de la tabla y vaya a Archivo > Área de impresión > Establecer área de impresión o Diseño de página > Área de impresión > Establecer área de impresión.
    • En versiones posteriores de Excel, las opciones de Área de impresión se encuentran en la pestaña Diseño de página.
  2. Vaya a Archivo > Guardar como y seleccione un formato compatible en las opciones disponibles en Excel. Haga clic en si Excel advierte de que algún formato no es compatible con este formato de archivo.
  3. Salga de Excel. Haga clic en No cuando Excel le pregunte si desea guardar los cambios.
Nota:
Si los cambios se guardan, Excel convierte el archivo en un libro .xls o .xlsx que solo se puede usar en ArcMap en la versión 9.2 y en versiones posteriores.
  1. Para agregar los datos del archivo .dbf, .csv, .txt o .prn a ArcMap, vaya a Herramientas > Agregar datos XY y seleccione el archivo.
    • En la versión 10.0, haga clic en el botón Agregar datos.
  2. Haga clic con el botón derecho en el nombre de la tabla y seleccione Mostrar datos XY.
Advertencia:
En la versión 10.0, ArcMap aplica el sistema de coordenadas del marco de datos a los datos XY. Es probable que este sistema de coordenadas sea incorrecto para los datos.
Haga clic en el botón Editar para abrir el cuadro de diálogo Propiedades de referencia espacial. Haga clic en el botón Seleccionar para seleccionar un sistema de coordenadas para los datos.
Nota:
Si se muestra un mensaje de advertencia que indica que falta el campo Object-ID, es seguro pasarlo por alto y hacer clic en Aceptar. 
[O-Image]

Como ejemplo, los datos GPS se capturan la mayoría de las veces en unidades de grados decimales o de lat/long, que es un sistema de coordenadas geográficas. Abra este directorio. En la mayoría de los casos, los datos GPS se capturan en el datum WGS 1984, así que abra la carpeta World y seleccione WGS_1984.prj.

Si los datos se han capturado en un datum diferente, haga clic en el vínculo titulado Sistemas de coordenadas geográficas y áreas de uso ,disponible en la sección Información relacionada situada más abajo, para encontrar el datum correcto.

  1. Después de definir la proyección, haga clic en Agregar, Aplicar y Aceptar en el cuadro de diálogo Propiedades de la referencia espacial. Haga clic en Aceptar en el cuadro de diálogo Agregar datos XY. Los puntos se dibujan como un tema de evento en ArcMap. Compruebe que el tema de evento se corresponde con los otros datos de ArcMap.
Nota:
Si los datos no se corresponden con los datos de referencia, consulte el siguiente artículo de la base de conocimiento: Cómo: Identificar la referencia espacial, la proyección o el sistema de coordenadas de los datos.
  1. Para convertir el tema de evento en un shapefile o una clase de entidad de geodatabase, haga clic con el botón derecho en el nombre del archivo y seleccione Datos > Exportar datos. Los puntos se pueden exportar a una clase de entidad de geodatabase o a un shapefile.
  2. Los datos también se pueden volver a proyectar en el sistema de coordenadas del marco de datos de ArcMap durante este proceso. Vaya a Ver > Propiedades del marco de datos > pestaña Sistema de coordenadas y seleccione la proyección de salida deseada para los datos de salida. Para proyectar durante la exportación, haga clic con el botón derecho en el tema Eventos, seleccione Datos > Exportar datos y cambie el botón de opción para exportar al "sistema de coordenadas del marco de datos". Los datos de salida estarán en el sistema de coordenadas de salida seleccionado.
  3. Para proyectar la capa de eventos en un sistema de coordenadas proyectadas mediante la herramienta Proyectar, siga estas instrucciones:
    1. En ArcMap, vaya a ArcCatalog > Cajas de herramientas > Cajas de herramientas del sistema > Herramientas de administración de datos > Proyecciones y transformación > Proyectar.
    2. En el cuadro de diálogo de la herramienta Proyectar, rellene los parámetros requeridos:
      • Clase de entidad o dataset de entrada: la clase de entidad, capa de entidades o dataset de entidades que se va a proyectar.
      • Sistema de coordenadas de entrada (opcional): el sistema de coordenadas de la clase de entidad o el dataset de entrada.
      • Sistema de coordenadas de salida: el sistema de coordenadas en el que se proyectarán los datos de entrada.
      • Transformación geográfica (opcional): se puede usar para convertir los datos entre dos sistemas de coordenadas geográficas o datums.
    3. Haga clic en Aceptar.
Nota:
Si ArcMap advierte de un "sistema de coordenadas geográficas diferente del de otros datos del mapa", vaya a Ver > Propiedades del marco de datos > pestaña Sistema de coordenadas, y haga clic en el botón Transformaciones para comprobar que se está usando la transformación de datum correcta para el área en la que se encuentran los datos.
Nota:
Para obtener una lista de las transformaciones geográficas (datum) y sus áreas de uso, vea el siguiente artículo: Cómo: Seleccionar la transformación geográfica (datum) correcta al proyectar entre datums. En la sección Información relacionada del artículo, descargue la lista de transformaciones para la versión de ArcGIS Desktop instalada en el equipo.

Información relacionada