Español

Cómo: Mostrar un archivo de dibujo de AutoCAD en ArcMap

Resumen

Este artículo proporciona instrucciones para agregar archivos de dibujo de AutoCAD en ArcMap, identificar problemas que puedan impedir que se dibujen los datos y sugerencias para corregir estos problemas en AutoCAD.

Procedimiento

Los pasos siguientes son útiles cuando se aplican a un archivo de dibujo de AutoCAD en la aplicación nativa, antes de agregar el archivo a ArcMap.

Nota:
ArcGIS Desktop no admite entidades creadas en AutoCAD Civil 3D o AutoCAD Land Desktop que usen datos Objeto. Si estos archivos se abren y se vuelven a guardar en AutoCAD, algunos de los datos Objeto pueden convertirse en entidades que se dibujan en ArcMap o se convierten en una geodatabase. Pero, si es posible, debe evitarse el uso de datos Objeto en los archivos de AutoDesk que se incorporan a ArcGIS Desktop.

  1. Crear una copia de un archivo de AutoCAD.

    a. Guarde una copia del archivo de dibujo en AutoCAD con un nombre que no contenga espacios ni guiones. Si el nombre contiene espacios o guiones, sustituya ambos caracteres por guiones bajos.
    b. Vaya a Insertar > Referencias externas y separa cualquier referencia externa adjunta al archivo. Guarde el archivo de dibujo de AutoCAD de nuevo.
    c. Vaya a Formato > Unidades. Tome nota de las unidades utilizadas para crear el archivo.
    d. Vaya a Administrador de capas y active, movilice o desbloquee todas las capas se estén desactivadas, inmovilizadas o bloqueadas. De esta forma se habilitan los datos para dibujarse en ArcMap.
    e. Guarde el archivo de dibujo de AutoCAD.
  2. Agregue el archivo de dibujo de AutoCAD a ArcMap para modificar entidades.

    a. Abra un mapa en blanco en ArcMap.
    [O-Image]

    b. Vaya a la barra de herramientas Herramientas y seleccione la lista desplegable Agregar datos.
    [O-Image]

    c. Vaya a la ubicación donde se ha guardado la nueva copia del archivo de dibujo de AutoCAD y haga doble clic en el archivo .dwg.
    [O-Image]

    d. Agregue individualmente los tipos de entidad del archivo. Esto ayuda a aislar los tipos de entidad que causan problemas.
    [O-Image]
    Nota:
    Agregar los tipos de entidad individualmente en ArcMap permite acceder a propiedades de capa individuales. Al agregar la capa de grupo se bloquea el acceso a esta información.


    Advertencia:
    Si surge algún problema con los datos que se muestran en la sesión de ArcMap, el archivo de dibujo de AutoCAD debe corregirse. Consulte los pasos 3-5.

  3. En ArcMap, quite las capas problemáticas de los archivos .dwg. Haga clic con el botón derecho del ratón en una capa específica y seleccione Quitar.
    [O-Image] [O]

  4. En AutoCAD, vaya a Editar > Seleccionar todo y aplique el comando Expandir para expandir los bloques.

    Nota:
    El comando Expandir puede causar que estén disponibles entidades no accesibles. Se recomienda aplicar el comando Expandir al menos una vez, aunque es posible que haya que aplicar el comando varias veces más debido a que los bloques pueden estar incrustados hasta en nueve niveles de profundidad.

  5. Guarde el archivo de dibujo de AutoCAD y repita el Paso 2.

Información relacionada