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Problema: problemas de rendimiento con ArcGIS for Desktop 10.x

Descripción

Hay varios casos en los que las aplicaciones de ArcGIS for Desktop se ven afectadas por un bajo rendimiento, por ejemplo al iniciar ArcMap o ArcCatalog, abrir un nuevo documento de mapa, inicializar las secuencias de comandos de ArcPy, exportar mapas a archivos PDF, etc.

Causa

El rendimiento de un equipo depende tanto de su hardware como de las especificaciones de software. Si los requisitos de hardware bastan para proporcionar un alto rendimiento para la carga actual del software, hay otros factores que consumen recursos del sistema y que pueden causar problemas de rendimiento.

Por tanto, el problema de rendimiento puede deberse a cualquiera de las siguientes causas:

• Hay muchas aplicaciones ejecutándose en segundo plano o durante el inicio, como Symantec AntiVirus, Citrix, Google Chrome etc.
• Hay distintos ajustes configurados en ArcMap.
• Los directorios de inicio del usuario se están redireccionando en Citrix.
• Hay aplicaciones de malware presentes en el equipo.
• Configuración de alimentación del sistema Windows o el equipo.

Solución o solución alternativa

Para optimizar el rendimiento de ArcGIS for Desktop y el equipo, puede usar las siguientes sugerencias.

A. Mejorar el rendimiento de ArcGIS for Desktop

• Si ArcGIS for Desktop se está ejecutando en un entorno de Citrix XenApp, deshabilite los redireccionamientos de carpeta en el nivel del servidor de terminal de Windows Server para impedir que los directorios de inicio de los usuarios se redireccionen.

• Cree conexiones con los directorios que contienen datos de la red en el nivel más bajo posible.

• Compruebe la capacidad del equipo para ejecutar ArcGIS: ¿Puede ejecutarlo?

• Borre la caché de visualización. La caché de visualización facilita el desplazamiento panorámico y el zoom en el mapa existente, pero si la caché se conserva en lugar de borrarse de un mapa al siguiente, el impacto en el rendimiento puede ser considerable. En ArcMap, haga clic en Personalizar > Opciones de ArcMap. En la pestaña Caché de visualización, haga clic en Borrar la caché.

Nota:
ArcMap está programado para comprobar la validez de todas las conexiones de carpeta de las rutas de la conexión especificada. Por ejemplo, si los datos deseados se encuentran a seis carpetas de profundidad en la estructura del directorio de red, el cuadro de diálogo Agregar datos verifica la validez de las seis carpetas antes de bajar al directorio que contiene los datos que el usuario desea agregar al mapa.

• Borre el historial de geoprocesamiento yendo a Geoprocesamiento > Opciones de geoprocesamiento y, en Gestión de resultados, cambie el ajuste a No guardar nunca o a Guardar resultados de menos de 1 día.

Nota:
Si se ejecutan muchas operaciones de geoprocesamiento desde ArcMap, validar el historial de estas operaciones para un periodo de dos semanas tienen un efecto considerable en el rendimiento.

• Minimice el número de conexiones de red al servidor que se guardan en un documento de ArcMap. Hay un impacto importante en el rendimiento si un MXD contiene muchas conexiones de red.

• Siempre que sea posible, defina la proyección del marco de datos de ArcMap en el sistema de coordenadas de cualquier dato ráster del mapa.

Nota:
Cuando las imágenes ráster se proyectan al vuelo, el rendimiento puede reducirse. Los datos vectoriales se proyectan al vuelo mucho más deprisa.

Para obtener más información, consulte el siguiente artículo de la Base de conocimiento: Cómo: mejorar el rendimiento trabajando en ArcMap y ArcCatalog.

B. Mejorar el rendimiento de Windows

• Descargue e instale la aplicación Monitor de procesos y ejecútela cuando intente agregar datos en ArcMap. Esta aplicación registra todas las operaciones realizadas en el equipo y la cantidad de tiempo que tarda en completarse cada operación. Los archivos PML creados por la aplicación contienen cientos de miles de entradas, ya que registra las horas de los eventos hasta una millonésima de segundo. Mediante el análisis de la salida, los usuarios pueden determinar qué aplicación del equipo está interfiriendo con el rendimiento de ArcGIS for Desktop. Descargue e instale la aplicación desde Windows Sysinternals.

• Descargue e instale la herramienta IOzone desde IZone Filesystem Benchmark. Esta herramienta es una aplicación de comparación de sistemas de archivos de código abierto muy popular. Evalúa el rendimiento del sistema y permite realizar una comparación entre el acceso de red a los datos y el acceso local.

Nota:
Ejecutar esta herramienta puede llevar muchas horas, dependiendo del estado de la red.

• Cree una lista blanca con algunas áreas del equipo para eliminar parte del trabajo repetitivo de análisis del antivirus.

• Ejecute la utilidad Desfragmentador de disco después de ejecutar Limpieza del disco con regularidad. Reinicie después.

Advertencia:
No ejecute Desfragmentador de disco en discos duros de estado sólido.

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