PROBLEMA

Las herramientas se abren con ventanas de diálogo en blanco

Last Published: April 25, 2020

Descripción

En algunas circunstancias, las herramientas de geoprocesamiento y las barras de herramientas se abren con ventanas de diálogo en blanco. Los botones (Aceptar, Cancelar, Entornos, etc.) siguen funcionando correctamente. También puede aparecer una barra de desplazamiento en la parte del cuadro de diálogo en la que se introducen los parámetros de entrada y salida, pero no son visibles los campos ni los ajustes.

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Causa

La clave de registro que hace referencia a vbscript.dll y a otras .dll necesarias para el funcionamiento de la herramienta se ven sobrescritos por el software antivirus McAfee. Al desinstalar el software antivirus McAfee, las claves del registro no se devuelven al formato nativo. Este problema también puede producirse con el software antivirus Avast. Para confirmar que esta es la causa, siga estos pasos:

  1. Abra el menú Inicio.
  2. Escriba regedit en el campo Buscar y, a continuación, pulse Intro.
  3. Busque las claves del registro que se indican a continuación y compruebe si coinciden.
 HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}
  • Compruebe que en la ventana de la derecha contenga un valor (Predeterminado) del tipo REG_SZ con el valor Datos definido como VB Script Language.
HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32
  • Compruebe que en la ventana de la derecha contenga un valor (Predeterminado) del tipo REG_SZ con el valor Datos definido como C:\Windows\system32\vbscript.dll.
HKEY_CLASSES_ROOT\CLSID\{EE09B103-97E0-11CF-978F-00A02463E06F}\InprocServer32
  • Compruebe que en la ventana de la derecha contenga un valor (Predeterminado) del tipo REG_SZ con el valor Datos definido como C:\Windows\system32\scrrun.dll.
[O-Image] Registry Editor
  1. Si alguna de las claves no coincide, pruebe la solución descrita a continuación.

Solución o solución alternativa

Si tiene instalado actualmente McAfee y desea seguir utilizándolo, póngase en contacto con McAfee para obtener ayuda. Si tiene instalado McAfee, pero no es necesario en el equipo, desinstálelo antes de continuar con la solución que se indica a continuación. Una vez desinstalado el software antivirus McAfee, siga los pasos que se indican a continuación para resolver el problema.

  1. Descargue la herramienta McAfee Consumer Product Removal (MCPR) y consulte las instrucciones: Cómo desinstalar o reinstalar los productos McAfee compatibles con la herramienta Consumer Product Removal (MCPR).
  2. Navegue hasta el directorio en el que se guardó el archivo MCPR.
  3. Haga clic con el botón derecho en MCPR.exe y elija Ejecutar como administrador.
  4. Siga las instrucciones.
  5. Cuando aparezca el mensaje Limpieza realizada correctamente, reinicie el equipo.

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