Español
Continue in the app

Parche 4 de red de servicios para ArcGIS Server 10.8.1

Resumen

Este parche soluciona varios problemas funcionales de la red de servicios de ArcGIS Enterprise 10.8.1 junto con mejoras de rendimiento en validación, seguimiento, actualización de subredes, así como mejoras de rendimiento generales para las geodatabases corporativas de SQL Server.

Descripción

Esri® anuncia el Parche 4 de red de servicios para ArcGIS Server 10.8.1. Este parche se centra en la calidad y el rendimiento, especialmente en las áreas de validación y actualización de subredes, y se recomienda para todos los clientes de la red de servicios que utilicen ArcGIS Enterprise 10.8.1. Los usuarios con geodatabases corporativas de SQL Server se beneficiarán de las actualizaciones que corrigen problemas con los procedimientos almacenados y el bloqueo interno. Además, este parche trata específicamente los problemas que se enumeran a continuación en Problemas solucionados con este parche.

Nota importante: Se requiere una actualización de geodatabase para las mejoras en SQL Server. Consulte la sección Actualizar una geodatabase que aparece a continuación para obtener instrucciones.


Problemas solucionados con este parche


  • BUG-000140539 - Las consultas STIntersects() no utilizan el índice espacial
  • BUG-000140525 - Implementar la optimización Validar trazar subredes sin validar. Cuando un nivel no contiene subredes, no traza el nivel ya que no se podría marcar nada como sin validar.
  • BUG-000140449 - Conexiones bloqueadas por el bloqueo de tabla exclusivo en sde_process_information.
  • BUG-000140443 - La validación de una entidad de contenido genera actualizaciones para todas las asociaciones de la entidad de contenedor
  • BUG-000140214 - La publicación mantiene un bloqueo de tabla compartido en gdb_itemtypes durante la operación de publicación
  • BUG-000140030 - Mejorar el rendimiento de las consultas en rama con unión de tablas de archivos de registro UUID.
  • BUG-000140013 - Se puede encontrar un bloqueo sin salida cuando varias conexiones mantienen bloqueos exclusivos en las tablas sde_process_information y sde_table_locks.
  • BUG-000139968 - La actualización puede crear un índice condicional incorrecto en la tabla GDB_Locks.
  • BUG-000139833 - Puede producirse un bloqueo mutuo en las tablas SDE_branches y SDE_branch_tables_modified durante las operaciones simultáneas de conciliación y publicación.
  • BUG-000139379 - La propagación de conflictos se produce incorrectamente en un escenario concreto con relaciones con atributos y versionado en rama.
  • BUG-000139299 - Rendimiento de edición en la topografía de red habilitada
  • BUG-000133185 - La herramienta 'Validar topología de red' falla y devuelve el siguiente mensaje de error: "Error de la operación de edición. ERROR:"
Para evitar conflictos en la versión 10.8.1, este parche también aborda lo siguiente:
  • BUG-000137346: el bloqueo se produce cuando se ejecuta la conciliación mientras que la tabla intermedia no está registrada como versionada.
  • BUG-000137139 - Optimizar la función UpdateAssociationInfo dividiendo la consulta para descubrir asociaciones from/toglobalid
  • BUG-000136979 - Validar topología de red asigna de forma incorrecta grandes cantidades de memoria, lo que afecta al uso de memoria SOC del servidor
  • BUG-000136930: en un servicio versionado en rama, con origen en una base de datos de PostgreSQL, cualquier interrupción de la conexión producirá un error de DBMS subyacente hasta que se reinicie el servicio.
  • BUG-000136892 - Cuando se devuelve -1 en ArcGIS Pro, el cuadro de diálogo de resolución de conflictos no puede presentar correctamente los conflictos
  • BUG-000136889 - Después de actualizar Enterprise Geodatabase 10.7.1 a 10.8.1 y ejecutar la consulta para obtener Next_RowID, se devuelve el siguiente mensaje de error: Msg 8144, Nivel 16, Estado 2, Procedimiento DBO.i13_get_ids, Línea 0 [Línea de inicio de lote 0] El procedimiento o la función i13_get_ids tiene demasiados argumentos especificados.
  • BUG-000136296 - Las conciliaciones antiguas pueden impedir que los usuarios editen la versión predeterminada o que concilien otras versiones con versionado en rama.
  • BUG-000136284 - La edición de datos que se registran como multirrama provoca escenarios de bloqueo y escalada en las geodatabases en SQL Server.
  • BUG-000136107: la herramienta Actualizar subred falla y devuelve el mensaje de error: "ERROR 001400: El servidor tardó demasiado en responder. El tiempo de espera del cliente ha expirado. (Código de estado 28). Error al ejecutar (UpdateSubnetwork)".
  • BUG-000135328 - La conciliación falla en una versión en rama y devuelve el mensaje de error "Ya existe una fila con este OID".
  • BUG-000135117 - La actualización de la subred en una red de servicios de referencia espacial de un sistema de coordenadas geográficas (GCS) falla la segunda vez en líneas cortas.
  • BUG-000134954 - La conciliación de varias versiones en la red de servicios mediante la herramienta Conciliar versiones bloquea la instancia de ArcSOC.exe.
  • BUG-000134950 - El bloqueo se produce cuando se ejecuta la conciliación mientras que la tabla de destino relacionada no estaba registrada como versionada
  • BUG-000134496 - Al utilizar la herramienta "Conciliar versiones" y dejar desactivado el parámetro "Anular si se detectan conflictos", la sesión sigue anulando la conciliación.
  • BUG-000134378 - Eliminar la función superior en columnas GUID en consultas de estructura de parcelas contra geodatabases corporativas de Oracle
  • BUG-000133698 - La habilitación de la topología con la opción " Generar solamente errores" no valida las áreas sin validar del error.
  • BUG-000132887 - Las líneas de subred eléctrica y las líneas eléctricas no se superponen cuando la red de servicios está en un GCS de "GDA2020".
  • BUG-000132751 - Optimizar las sentencias SQL de las consultas versionadas en rama cuando se utilice una geodatabase corporativa Oracle
  • BUG-000132315 - Eliminar cláusula "donde 1=1" innecesaria de las consultas del servicio de entidades
  • BUG-000130888 - La herramienta Registrar con geodatabase falla cuando se registra una clase de entidad vacía.
  • BUG-000130742 - Optimizar las consultas de paginación versionadas en rama cuando se utilice una geodatabase corporativa en Oracle

Instalar este parche en Windows


Pasos para la instalación:


Este parche debe instalarse en todas las instalaciones de ArcGIS Server relacionadas con el sitio de ArcGIS Server.

El producto ArcGIS que aparece en la tabla debe estar instalado en su sistema para poder instalar un parche. Cada configuración de parche es específica del producto ArcGIS de la lista. Para determinar qué productos están instalados en su sistema, consulte la sección Cómo identificar qué productos de ArcGIS están instalados. Esri recomienda que instale el parche para cada producto que esté instalado en su sistema.

  1. Descargue los archivos adecuados en una ubicación que no sea la de instalación de ArcGIS.

  2. ArcGIS 10.8.1  
       
         ArcGIS Server ArcGIS-1081-S-UN4-Patch.msp
         Suma de comprobación
         (SHA256)
    AFFACC045B1ECBB815A4194D2B15C33B2BAADFD5C47938AAA29639587809C060
       

  3. Asegúrese de que tiene acceso de escritura a la ubicación de instalación de ArcGIS.

  4. Haga doble clic en ArcGIS-1081-S-UN4-Patch.msp para iniciar el proceso de instalación.

    NOTA: Si haciendo doble clic en el archivo MSP no se inicia la instalación, puede iniciarla manualmente utilizando el siguiente comando:

    msiexec.exe /p [ubicación del parche]\ArcGIS-1081-S-UN4-Patch.msp


Instalar este parche en Linux


Pasos para la instalación:


Complete los siguientes pasos de instalación como propietario de instalación de ArcGIS. El propietario de instalación es el propietario de la carpeta arcgis. Este parche debe instalarse en todas las instalaciones de ArcGIS Server relacionadas con el sitio de ArcGIS Server.

El producto ArcGIS que aparece en la tabla debe estar instalado en su sistema para poder instalar un parche. Cada configuración de parche es específica del producto ArcGIS de la lista. Para determinar qué productos están instalados en su sistema, consulte la sección Cómo identificar qué productos de ArcGIS están instalados. Esri recomienda que instale el parche para cada producto que esté instalado en su sistema.

  1. Descargue los archivos adecuados en una ubicación que no sea la de instalación de ArcGIS.


    ArcGIS 10.8.1  
       
         ArcGIS Server ArcGIS-1081-S-UN4-Patch-linux.tar
         Suma de comprobación
         (SHA256)
    4A9BC41D207926EE64FE60D04077D3CDAA0F3C7174A5C8DFA36D3BC9327BCA88
       

  2. Asegúrese de que tiene acceso de escritura a la ubicación de instalación de ArcGIS y de que nadie está usando ArcGIS.

  3. Extraiga el archivo tar específico escribiendo:

    % tar -xvf ArcGIS-1081-S-UN4-Patch-linux.tar

  4. Inicie la instalación escribiendo:

    % ./applypatch

    Esto iniciará el cuadro de diálogo para el procedimiento de instalación basado en menús. Las selecciones predeterminadas se anotan entre paréntesis ( ). Para salir del proceso de instalación, escriba 'q' en cualquier momento.

Actualizar una geodatabase


Cuando se ha aplicado una corrección urgente o un parche para ArcGIS, también puede ser necesario actualizar su geodatabase. Consulte la sección Actualizar la geodatabase en la página Administración de geodatabase sobre su plataforma DBMS individual para obtener más información.

Sugerencia: Actualice sus geodatabases corporativas almacenadas en Microsoft SQL Server para aprovechar las correcciones críticas del versionado en rama.

Actualizar desde ArcGIS Server requiere el uso de Python. Si está trabajando con ArcGIS Server en Windows o Linux, puede acceder al entorno adecuado de Python 3 utilizando python.exe, incluido con los componentes de marco/tiempo de ejecución de ArcGIS Server. Además, en Windows hay disponible un archivo de lotes de script para iniciar el entorno de Python 3.

Para realizar la actualización, cree un script con esta sintaxis de Python de ejemplo y asigne al script el nombre upgrade_gdb.py.

import arcpy
Connection_File_Name_full_path="C:\\temp\\sysadmin_connection.sde"
arcpy.UpgradeGDB_management(Connection_File_Name_full_path, "PREREQUISITE_CHECK", "UPGRADE")

En este tema de ayuda hay disponible documentación adicional sobre cómo Actualizar una geodatabase corporativa en SQL Server: Actualizar una geodatabase corporativa en SQL Server

En Windows, ejecute el script explícitamente utilizando el entorno de Python 3. Si ArcGIS Server se instala en la ubicación predeterminada, el script se puede ejecutar con uno de los siguientes comandos:

"C:\Archivos de programa\ArcGIS\Server\framework\runtime\ArcGIS\bin\Python\scripts\propy.bat" C:\temp\upgrade_gdb.py
O
"C:\Archivos de programa\ArcGIS\Server\framework\runtime\ArcGIS\bin\Python\envs\arcgispro-py3\python.exe" C:\temp\upgrade_gdb.py

En Linux, inicie el entorno de Python 3 utilizando los comandos siguientes:

source /<arcgis_server_installation_directory>/arcgis/server/framework/etc/arcenv
unset LD_PRELOAD
unset CONDA_DEFAULT_ENV

Y después ejecute el script de actualización con el siguiente comando:

wine "Z:\<arcgis_server_installation_directory>\arcgis\server\framework\runtime\ArcGIS\bin\Python\envs\arcgispro-py3\python.exe" <path_To>\upgrade_gdb.py


Desinstalar este parche en Windows


Para desinstalar este parche en Windows, abra el panel de control de Windows y vaya a los programas instalados. Asegúrese de que "Ver actualizaciones instaladas" (en la parte superior izquierda del cuadro de diálogo Programas y características) esté activado. Seleccione el nombre del parche en la lista de programas y haga clic en Desinstalar para eliminar el parche.

Desinstalar este parche en Linux


Para eliminar este parche en las versiones 10.7 y posteriores, vaya al directorio <Product Installation Directory>/.Setup/qfe y ejecute el siguiente script como propietario de la instalación de ArcGIS:



./removepatch.sh

El script removepatch.sh le permite desinstalar parches o correcciones urgentes instalados anteriormente. Utilice el marcador de estado -s para obtener la lista de parches o correcciones urgentes instalados, ordenados por fecha. Utilice el marcador -q para eliminar parches o correcciones urgentes en orden cronológico inverso por su fecha de instalación. Escriba removepatch -h para obtener detalles de uso.

Reinicie sus servicios de ArcGIS.



Actualizaciones de parches

Compruebe la página Parches y Service Packs periódicamente para ver si hay parches adicionales disponibles. La información más reciente sobre este parche se publicará aquí.

2 de diciembre de 2021 La instalación de Windows de este parche se ha actualizado con nuevas firmas digitales. Este cambio soluciona el posible error de instalación:

Un certificado obligatorio no se encuentra dentro del periodo de validez cuando se comprueba con el reloj del sistema actual o la marca de tiempo del archivo firmado.

Cómo identificar qué productos de ArcGIS están instalados

Para determinar qué productos de ArcGIS están instalados, elija la versión apropiada de la utilidad PatchFinder para su entorno y ejecútela en su equipo local. PatchFinder enumerará todos los productos, correcciones urgentes y parches instalados en su equipo local.

Obtener ayuda

Para los sitios nacionales, póngase en contacto con Soporte técnico de Esri al 1-888-377-4575, si tiene alguna dificultad en instalar este parche. Para los sitios internacionales, póngase en contacto con su distribuidor de software Esri local.