Español
Continue in the app

Parche 3 de red de servicios para ArcGIS Server 10.8.1

Resumen

Este parche soluciona varios problemas funcionales con la versión 10.8.1 de la red de servicios. Además de los problemas enumerados a continuación, el parche aborda el rendimiento con la validación, el trazado poligonal y la actualización de subredes específicamente para redes jerárquicas.

Descripción

Esri® anuncia el Parche 3 de red de servicios para ArcGIS Server 10.8.1. Este parche se centra en la calidad y el rendimiento, especialmente en las áreas de validación y actualización de subredes, y se recomienda para todos los clientes de la red de servicios que utilicen ArcGIS Enterprise 10.8.1. Los usuarios que cuentan con subredes jerárquicas (gas y agua) se beneficiarán de las actualizaciones que resuelven los problemas de validación, trazado poligonal y actualización de subredes que no se completan cuando existen subredes grandes en la jerarquía. Además, este parche trata específicamente los problemas que se enumeran a continuación en Problemas solucionados con este parche.


Problemas solucionados con este parche


  • BUG-000136889 - Después de actualizar Enterprise Geodatabase 10.7.1 a 10.8.1 y ejecutar la consulta para obtener Next_RowID, se devuelve el siguiente mensaje de error: Msg 8144, Nivel 16, Estado 2, Procedimiento DBO.i13_get_ids, Línea 0 [Línea de inicio de lote 0] El procedimiento o la función i13_get_ids tiene demasiados argumentos especificados.
  • BUG-000136296 - Las conciliaciones antiguas pueden impedir que los usuarios editen la versión predeterminada o que concilien otras versiones con versionado en rama.
  • BUG-000135328 - La conciliación falla en una versión en rama y devuelve el mensaje de error "Ya existe una fila con este OID".
  • BUG-000135117 - La actualización de la subred en una red de servicios de referencia espacial de un sistema de coordenadas geográficas (GCS) falla la segunda vez en líneas cortas.
  • BUG-000134954 - La conciliación de varias versiones en la red de servicios mediante la herramienta Conciliar versiones bloquea la instancia de ArcSOC.exe.
  • BUG-000134950 - El bloqueo se produce cuando se ejecuta la conciliación mientras que la tabla de destino relacionada no estaba registrada como versionada
  • BUG-000134496 - Al utilizar la herramienta "Conciliar versiones" y dejar desactivado el parámetro "Anular si se detectan conflictos", la sesión sigue anulando la conciliación.
  • BUG-000133698 - La habilitación de la topología con la opción " Generar solamente errores" no valida las áreas sin validar del error.
  • BUG-000132887 - Las líneas de subred eléctrica y las líneas eléctricas no se superponen cuando la red de servicios está en un GCS de "GDA2020".
  • BUG-000130888 - La herramienta Registrar con geodatabase falla cuando se registra una clase de entidad vacía.
Para evitar conflictos, este parche también aborda lo siguiente:
  • BUG-000137139 - Optimizar la función UpdateAssociationInfo dividiendo la consulta para descubrir asociaciones from/toglobalid
  • BUG-000136979 - Validar topología de red asigna de forma incorrecta grandes cantidades de memoria, lo que afecta al uso de memoria SOC del servidor
  • BUG-000136892 - Cuando se devuelve -1 en ArcGIS Pro, el cuadro de diálogo de resolución de conflictos no puede presentar correctamente los conflictos
  • BUG-000136296 - Las conciliaciones antiguas pueden impedir que los usuarios editen la versión predeterminada o que concilien otras versiones con versionado en rama.
  • BUG-000136284 - La edición de datos que se registran como multirrama provoca escenarios de bloqueo y escalada en las geodatabases en SQL Server.
  • BUG-000135328 - La conciliación falla en una versión en rama y devuelve el mensaje de error "Ya existe una fila con este OID".
  • BUG-000135117 - La actualización de la subred en una red de servicios de referencia espacial de un sistema de coordenadas geográficas (GCS) falla la segunda vez en líneas cortas.
  • BUG-000134954 - La conciliación de varias versiones en la red de servicios mediante la herramienta Conciliar versiones bloquea la instancia de ArcSOC.exe.
  • BUG-000134950 - El bloqueo se produce cuando se ejecuta la conciliación mientras que la tabla de destino relacionada no estaba registrada como versionada
  • BUG-000134496 - Al utilizar la herramienta "Conciliar versiones" y dejar desactivado el parámetro "Anular si se detectan conflictos", la sesión sigue anulando la conciliación.
  • BUG-000133698 - La habilitación de la topología con la opción " Generar solamente errores" no valida las áreas sin validar del error.
  • BUG-000132887 - Las líneas de subred eléctrica y las líneas eléctricas no se superponen cuando la red de servicios está en un GCS de "GDA2020".

Instalar este parche en Windows


Pasos para la instalación:


Este parche debe instalarse en todas las instalaciones de ArcGIS Server relacionadas con el sitio de ArcGIS Server.

El producto ArcGIS que aparece en la tabla debe estar instalado en su sistema para poder instalar un parche. Cada configuración de parche es específica del producto ArcGIS de la lista. Para determinar qué productos están instalados en su sistema, consulte la sección Cómo identificar qué productos de ArcGIS están instalados. Esri recomienda que instale el parche para cada producto que esté instalado en su sistema.

  1. Descargue los archivos adecuados en una ubicación que no sea la de instalación de ArcGIS.

  2. ArcGIS 10.8.1  
       
         ArcGIS Server ArcGIS-1081-S-UN3-Patch.msp
         Suma de comprobación
         (SHA256)
    24F1B62E167BD23B26320BB6A8F9831032290F4EF33EABCD72B25F742B271DBD
       

  3. Asegúrese de que tiene acceso de escritura a la ubicación de instalación de ArcGIS.

  4. Haga doble clic en ArcGIS-1081-S-UN3-Patch.msp para iniciar el proceso de instalación.

    NOTA: Si haciendo doble clic en el archivo MSP no se inicia la instalación, puede iniciarla manualmente utilizando el siguiente comando:

    msiexec.exe /p [ubicación del parche]\ArcGIS-1081-S-UN3-PatchB.msp


Instalar este parche en Linux


Pasos para la instalación:


Complete los siguientes pasos de instalación como propietario de instalación de ArcGIS. El propietario de instalación es el propietario de la carpeta arcgis. Este parche debe instalarse en todas las instalaciones de ArcGIS Server relacionadas con el sitio de ArcGIS Server.

El producto ArcGIS que aparece en la tabla debe estar instalado en su sistema para poder instalar un parche. Cada configuración de parche es específica del producto ArcGIS de la lista. Para determinar qué productos están instalados en su sistema, consulte la sección Cómo identificar qué productos de ArcGIS están instalados. Esri recomienda que instale el parche para cada producto que esté instalado en su sistema.

  1. Descargue los archivos adecuados en una ubicación que no sea la de instalación de ArcGIS.


    ArcGIS 10.8.1  
       
         ArcGIS Server ArcGIS-1081-S-UN3-Patch-linux.tar
         Suma de comprobación
         (SHA256)
    D57F4CF755AF8FBBD19E8FDEE283143AD21271E00CC5E80FD71316C5B466E036
       

  2. Asegúrese de que tiene acceso de escritura a la ubicación de instalación de ArcGIS y de que nadie está usando ArcGIS.

  3. Extraiga el archivo tar específico escribiendo:

    % tar -xvf ArcGIS-1081-S-UN3-Patch-linux.tar

  4. Inicie la instalación escribiendo:

    % ./applypatch

    Esto iniciará el cuadro de diálogo para el procedimiento de instalación basado en menús. Las selecciones predeterminadas se anotan entre paréntesis ( ). Para salir del proceso de instalación, escriba 'q' en cualquier momento.

Desinstalar este parche en Windows


Para desinstalar este parche en Windows, abra el panel de control de Windows y vaya a los programas instalados. Asegúrese de que "Ver actualizaciones instaladas" (en la parte superior izquierda del cuadro de diálogo Programas y características) esté activado. Seleccione el nombre del parche en la lista de programas y haga clic en Desinstalar para eliminar el parche.

Desinstalar este parche en Linux


La desinstalación en Linux solo está disponible en la versión 10.5.1 o posteriores. Estas instrucciones son específicas para la versión 10.7 y posteriores. Para eliminar este parche, vaya a la carpeta <Directorio de instalación del producto>/.Setup/qfe y ejecute el siguiente script como propietario de la instalación de ArcGIS:


./removepatch.sh

El script removepatch.sh le permite desinstalar parches o correcciones urgentes instalados anteriormente. Utilice el marcador de estado -s para obtener la lista de parches o correcciones urgentes instalados, ordenados por fecha. Utilice el marcador -qpara eliminar parches o correcciones urgentes en orden cronológico inverso por su fecha de instalación. Escriba removepatch -h para obtener detalles de uso.

Actualizaciones de parches

Compruebe la página Parches y Service Packs periódicamente para ver si hay parches adicionales disponibles. La información más reciente sobre este parche se publicará aquí.

24 de noviembre de 2021 La instalación de Windows de este parche se ha actualizado con nuevas firmas digitales. Este cambio soluciona el posible error de instalación:

Un certificado obligatorio no se encuentra dentro del periodo de validez cuando se comprueba con el reloj del sistema actual o la marca de tiempo del archivo firmado.

Cómo identificar qué productos de ArcGIS están instalados

Para determinar qué productos de ArcGIS están instalados, elija la versión apropiada de la utilidad PatchFinder para su entorno y ejecútela en su equipo local. PatchFinder enumerará todos los productos, correcciones urgentes y parches instalados en su equipo local.

Obtener ayuda

Para los sitios nacionales, póngase en contacto con Soporte técnico de Esri al 1-888-377-4575, si tiene alguna dificultad en instalar este parche. Para los sitios internacionales, póngase en contacto con su distribuidor de software Esri local.