PROBLEMA

No se puede cambiar el nombre de las geodatabases de archivos en ArcMap

Last Published: October 1, 2025

Descripción

Al intentar cambiar el nombre de una geodatabase de archivos, aparece el siguiente error:

Error: Error al cambiar el nombre del objeto.

Causa

Hay dos causas posibles:

  • Existe un archivo .lock para la geodatabase. Los archivos .lock se crean cuando un proceso accede al dataset.
  • El software antivirus impide el cambio de nombre de la geodatabase.
Nota: En algunos casos, los archivos .lock se pueden dejar en la carpeta de la geodatabase después (por ejemplo, cuando un proceso finaliza prematuramente).

Solución o solución alternativa

Utilice una de las siguientes soluciones para resolver este problema.

  • Reinicie ArcMap para finalizar el proceso. Si los archivos .lock permanecen después de finalizar el proceso, elimine los archivos .lock manualmente. Para obtener más información, consulte Preguntas frecuentes: ¿Por qué los archivos .lock de la geodatabase de archivos permanecen después de finalizar un proceso?
  • Agregue excepciones para todas las aplicaciones de ArcGIS al software antivirus.
  • Reubique temporalmente el archivo .gdb y el archivo .gdb de copia de seguridad.
    1. Vaya a la siguiente ubicación de la carpeta .gdb.
    2. Mueva la carpeta .gdb a otra ubicación.
    3. Inicie ArcCatalog.
    4. Copie y pegue la carpeta .gdb reubicada anteriormente en la ubicación de la carpeta principal y cambie el nombre del archivo.
Nota: Se puede crear una geodatabase de archivos de copia de seguridad creando una nueva geodatabase de archivos y cargando en ella los datos deseados, o copiando la carpeta .gdb en otra unidad.

Id. de artículo: 000012446

Obtenga soporte con IA

Resuelva su problema rápidamente con el chatbot de inteligencia artificial de soporte de Esri.

Empieza a chatear ahora

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Empieza a chatear ahora

Ir a opciones de descarga