Mensaje de error
En una implementación con varios equipos para ArcGIS Enterprise 11.x o versiones anteriores, la impresión de mapas a veces no funciona correctamente y da un error. Es muy difícil solucionar esto porque muestra el estado "Iniciado" en ArcGIS Server Manager o en el punto final de Admin.
Normalmente, se devuelven los siguientes mensajes de error.
Error executing tool. Export Web Map Task : Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service1_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service2_Name>/MapServer.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service3_Name>/FeatureServer/0.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service4_Name>/FeatureServer/1.
Failed to create layer from service at https://machine.domain.in/arcgis/rest/services/<Service5_Name>/FeatureServer/0.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task).
An unexpected error occurred while printing from Map Viewer on ArcGIS Enterprise Portal.
Algunos ejemplos de cómo esto aparece al imprimir desde una aplicación personalizada se muestran en las siguientes capturas de pantalla.


Causa
Existen varias razones para este problema.
- La URL predeterminada del servicio de Herramientas de impresión no está configurada en: ArcGIS Enterprise Portal > Configuración > Configuración > Servicios de utilidades > Impresión
- El certificado SSL no está configurado correctamente en cada componente de ArcGIS Enterprise.
- Casos en los que existe una separación DMZ (zona desmilitarizada) o MZ (zona militarizada) de equipos en el entorno, por ejemplo, los componentes de ArcGIS Enterprise se separan en dos zonas para diferentes niveles de seguridad.
- El proxy de reenvío se utiliza para acceder a Internet en equipos ArcGIS Server, si este equipo se encuentra en una zona de misión en la que no hay conexión a Internet para acceder a las direcciones URL en línea.
- La comunicación interna entre los equipos que forman parte de ArcGIS Enterprise no funciona correctamente. Debe comprobarse la conectividad y los puertos necesarios.
Solución o solución alternativa
Los pasos que se indican a continuación han funcionado en configuraciones de alta disponibilidad para ArcGIS Enterprise 11.x.
- Configuración de la URL predeterminada del servicio Herramientas de impresión en: ArcGIS Enterprise Portal, pestaña Organización > Configuración > Servicios de utilidades > Impresión
https://machine.domain.in/arcgis/rest/services/Utilities/PrintingTools/GPServer
- donde "machine.domain.in" es el DNS público configurado para hacer accesible ArcGIS Enterprise a través de Internet. De lo contrario, es la URL del portal empresarial de ArcGIS.
- Configuración correcta del certificado SSL en cada componente de ArcGIS Enterprise:
- Configure el certificado SSL firmado por la CA o firmado por dominio correspondiente en cada equipo:
- ArcGIS Server (Alojamiento): cada equipo participante
- Portal de ArcGIS Enterprise: tanto principal como secundario
- ArcGIS Datastore: tanto primario como en espera
- Cualquier otra función o equipo de ArcGIS Server federada con ArcGIS Enterprise
- Si hay una separación DMZ o MZ de equipos en el entorno y se utiliza un proxy de reenvío para acceder a Internet en equipos ArcGIS Server, configure un servidor proxy de reenvío con ArcGIS Server en 11.x siguiendo estos pasos:
- Inicie sesión en la siguiente URL con la cuenta principal de administrador del sitio:
https://machine.domain.com:6443/arcgis/admin
- Haga clic en Sistema > Propiedades > Actualizar
Consulte las instrucciones a continuación para configurar el proxy directo en equipos con Windows y Linux: